Blender's text handling is not doing it for me

OK, so I want to paste some text into Blender. Sounds simple enough, right?
Well actually it’s frustrating me to no end.

Firstly, Blender has it’s own clipboard that doesn’t talk to my computer’s clipboard. I wouldn’t mind retyping if it were just a couple of words, but I want to input special characters - specifically the signs of the zodiac. The characters are included in many common fonts such as Arial. But since I know of no way to type these they must be copied and pasted into Blender.

I finally found a way around the separate clipboard issue. I made a .txt file with the characters I needed and saved it to my hard drive. Then in Blender I pulled up the Text Editor view and chose Text > Open. The characters showed up. Yay!
Then I copied the characters within Blender and attempted to paste them in as 3D text. All I got was four “missing character” boxes. That is so lame.

Does anybody know a workaround for this? :ba:

Don’t use text, use Illustrator or inkscpae to layout your text then save it as a SVG. Then import the SVG into Blender 2.49. No font mangling will occur with this work flow. You will still have a curve that you can extrude and bevel as you see fit.

Good advice, Atom. I can’t believe I never thought of that. Peace.

Alright, I reverted to 2.49b and imported my Inkscape .svg file but nothing shows up… any idea why?

I was presented with some options when importing, but I just went with the default settings. (See attached screen shot.)

Attachments


Have you tested that the SVG file actually loads in Illustrator? Maybe the SVG file is blank?

Ah! You were right. There is a problem with the SVG file. But it’s a font problem.

What do you have to do in Inkscape to convert text into a symbol?
(I’m using Flash terminology here because I’m new to Inkscape. Hopefully somebody will understand what I mean.)

Otherwise, I may have to use Illustrator… but I can’t get zodiac sign characters to show up in Illustrator either. (They show up in plaintext files just fine - go figure!)

Attachments