BlendFarm, A free, cross-platform, stand-alone, open-source Network Renderer

Wow, fast response!! Thanks, yeah, I tried a wget command and it worked fine. When I set up the connection to the server from the other PC, is used the IP address 192.168.1.82:15000, I’m not sure why its showing that IP on the server end.

Here’s the output from wget.
Hopefully you have more ideas! :slight_smile:

Thanks!
Mike

Connecting to download.blender.org (download.blender.org)|82.94.213.221|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 166837348 (159M) [application/octet-stream]
Saving to: ‘blender-2.93.5-linux-x64.tar.xz’

blender-2.93.5-linux-x64.tar.xz 100%[==================================================================================================>] 159,11M 1,59MB/s in 3m 7s

2021-11-02 21:34:22 (872 KB/s) - ‘blender-2.93.5-linux-x64.tar.xz’ saved [166837348/166837348]

Odd, seems fine. Thats really the only thing that came to mind. “Operation timeout” can only really be related to the web request it does. Maybe just give it another try?
Alternative thing you could try, try copying your VersionCache (on a pc that does work, eg. your client) to the server’s directory and ensure access read/write/execute.
This way the server does not have to fetch versions, but does try to download the Blender install files (like you just did).

The other option is that perhaps the disk operation times out? I doubt this is the case, seems unlikely.
So it is likely something to do with internet access for BlendFarm. I could verify tomorrow if there is any other operation that could time out, but I doubt it.

Finally, if for whatever reason you cannot get it working, you can manually place a blender installation in the right directory. This way the server does not need to download the blender installation, this is really not the way you want BlendFarm to work. To do this, You place an extracted Blender installation into BlendFarmDirectory/BlenderData/blender-2.93.5-linux64 (blender.exe/etc should be located directly under that folder), then ensure permissions chmod -R u=rwx BlenderData (you should know the drill on Linux).
Folder structure would look something like this

  • BlendFarm.Server
    • LogicReinc.BlenderFarm.Server
    • BlenderData
      • blender-2.93.5-linux64
        • blender.exe

Hi there, I’m currently trying to set up multiple Nodes to work with but One of the nodes seems to fail connecting to the host:

Is there something I’m doing wrong or is the issue perhaps with the networking?
Just to add I’m using a single profile to remotely access the other Nodes.

At a glance it appears the render node is closing the connection immediately (Expected header of length 24, received 0). It might also be a networking issue. Perhaps firewall?

One other option is that the render node version is very old, but since you’re saying you just tried setting it up I assume its the latest build.

With the info I got this is all I can tell you, I do hope it helps.