Blendigo+Ubuntu=insanity. Sticky thread on Blendigo, anyone?

OK.
A lot of threads about this great but problematic piece of software.
And many of them present diferent issues, not really related, so i couldn’t add this call for help at any of those previos threads, cause i havn’t read of anyone having this same problem with Blendigo.

Indigorenderer and its Blender exporter Blendigo are great. No problem working with them in Windows. But i wish to go Linux, so i got the following elements in my PC:

-Blender 2.48a, working fine
-Indigo 2.0.12 32bits for Linux, apparently working fine, cause Indigo GUI shows up by dobleclicking the Indigo icon.
-Blendigo 2.0.10, fow Windows, cause ther’s not a Linux version and you have to Wine it.
-Python 2.5 and 2.6.

So i had (and have) Blender 2.48a workinf perfectly in Linux. Then downloaded and unpacked indigo tar.gz in a folder named indigo in my personal folder
(/home/mark/indigo)
Then instaled, using wine, Blendigo 2.0.10, pointing the path to the Blender scripts folder at /usr/share/blender/scripts/blender.

I also read something about modifying a file named indigowrapper.conf, located (in my case) at /usr/share/blender/bpydata after the installation. The modification consisted on writhing the path of the Indigo launcher, and in my case it wal already set the right way (/home/mark/indigo).

I did already all those thing under Windows, with the corresponding folders of course, and it worked

now, in ubuntu, i got a nice model, a sunlamp, switched to Scripts/Render/Render With indigo
This error message came up:“ERROR, broken installation of Indigo, Prealse reinstall - Ckeck console”
And the console (the error message in bold) :[email protected]:~$ blender
Compiled with Python version 2.6.2.
Checking for installed Python… got it!
Traceback (most recent call last):
File “<string>”, line 1, in <module>
File “/home/mark/.blender/scripts/blender/blendigo.py”, line 64, in <module>
indigoLogo = Blender.Image.Load(os.path.join(assetsPath, “indigo_logo.png”))
IOError: couldn’t load image

As you can read in the last three lines, the error is about the lack of a file named indigo_logo.png; it oculdn be loaded.

So, being young and naive and unexperienced, i thought tat may be the simple solution would be to edit the Blendigo.py so hat it wolud look for the PNG at the folder where it actually was, /home/mark/indigo/icons.

Did it, went for another render and got this:----------------------
BLENDIGO v2.0.10

Linux-platform: linux2 os.sep: /

Traceback (most recent call last):
File “/home/mark/.blender/scripts/blender/blendigo.py”, line 3624, in event
materialEvent(evt, val)
File “/home/mark/.blender/scripts/blender/blendigo.py”, line 1519, in materialEvent
readWriteMaterial(activeMaterial, 0)
File “/home/mark/.blender/scripts/blender/blendigo.py”, line 443, in readWriteMaterial
convertMaterial(m)
File “/home/mark/.blender/scripts/blender/blendigo.py”, line 406, in convertMaterial
drawGUI()
File “/home/mark/.blender/scripts/blender/blendigo.py”, line 3507, in drawGUI
responsecurvepath = os.path.join(indigo.getResourcesPath(),“data\camera_response_functions”)
NameError: global name ‘indigo’ is not defined

AH!; I CAN’T STAND IT ANYMORE - GET ME A F***NG DOCTOR! AAAH!
Uf. Ejhm. Any ideas?.

At least, could anyone remember me (cause i knew hot to but totally forgot) how to manualy render with Indigo, with no exporter involved?, i recall something about generating an XML and editing it or something.

I haven’t used the new version of Indigo, so I don’t know how the exporter works now(What do you mean you have to Wine it? I thought the exporter was a python file.).

Anyway, did you know you have a .blender/scripts folder in /home/mark ?
Check ‘View -> Show Hidden Files’, and check that Blender’s default python scripts path in User Preferences points to the scripts folder with the scripts you are using.

WELL YES ORGANIC IT WORKED!

Well, at least now i don’t get the error msg. But when i hit RENDER SCENE nothing happens. The screen just stays the same, no renderization process appears.

In this case the console reads “sh: /usr/bin/open: not found”

No idea what that would be.

I’m guessing, do you have qt installed? I think you need qt-4.5 (might be called libqt4)

If it still doesn’t work you could try asking at the Indigo forums, someone there should know, though I don’t know how much traffic it gets.

Hi Grotesque,

I looked up the bug you’re getting and have made some fixes. Can you try and download this linux package and run the installer contained in it?

http://www.indigorenderer.com/dist/exporters/blendigo-linux-2.2.1.tar.gz

If it works well we’ll make a new release of Indigo.

Ben