Blendit - Full dynamic material blending of objects

Hello Julien.
I tested the Simple deform modifier and it works for me.
I can’t successfully replicate the error. Can you please share a .blend file?

1 Like

is this supposed to work with blender 2.91? i bought the addon, but blender just freezes, when trying to “create dynamic blends”, this happens even with two materials having just some plain color set

It works here. I’m on 2.91.2

Do you have any other add-on installed? If you haven’t done it yet, maybe try running Blendit after a clean installation.

Hello.
The add-on works with version 2.91. Can you share a .blend file that causes a issue?

it seems to be related to my fedora 33 rpm install of blender 2.91 and/or the local python setup (or me having it messed up), using the flatpak version, a binary from blender.org, or even an 2.93 based alpha of UPBGE 0.3, it does indeed work!

Hello Julien.
Thanks for .blend file, here is what I found.

  • Some issues from your log are warnings about broken drivers in your scene (They can be cleared manually in the Blender Driver editor). This can happen if Blendit modifiers are removed by hand without using the Blendit function: Remove Blends.

  • I’m not sure what is wrong with no moving plants, but there is probably no problem with Blendit if your final render is ok. If there are problems with modifiers such as Simple Deform, try to check the order of modifiers. Blendit modifiers should be at the end of the stack.

  • Blendit also works on particles. Blended objects cannot be used directly in a particle system. The blended object must first use the Particle Instance modifier instead.

1 Like

Does this work with the new Geo node Feature from Blender 2.92?

yep
The add-on works with Geo Nodes without any problems, but the current version doesn’t use it itself. If you find any issues, report it and I will try to help you.
I’m also experimenting with the new Geo Node systems and hope for a huge performance improvement for the new version of Blendit.
Every Geometry Nodes update is changing a lot of things right now.

2 Likes

Hey there. I’ve just bought your plugin and tried to blend an object with geometry nodes ( point instancing) with another object with geometry nodes (also point instancing) and it doesn’t work for some reason. I think it has something to do with target object having geometry nodes, because If the target object doesn’t have any geometry nodes, it works. It doesn’t matter If the source has it. I am not sure If this is an issue or it is something about my scene but I wanted to share, maybe a possible solution exists?

Hey dorukcandan.
Geometry Nodes is a brand new feature of Blender with unfinished development, and not everything may work as you expect. Some modifiers are still not compatible with certain Geometry Nodes setups. There are several bugs reported to Blender developers. I recommend to wait for bug fixes in the latest future Blender builds or not to use specific nodes. For example, I found Blender issues with the Join Geometry and Point Instance nodes, as you mentioned. Instead Join Geometry node, you can try to use a Boolean node. Instead of Geometry Nodes with Point Instance, I recommend using the Particle Instance modifier for now.

1 Like

Do you consider to offfer BlendIt also on Blendermarket?

Yes, next release I plan also on Blendermarket. Higher Tiers on Gumroad will always have an advantage.

2 Likes

I just purchased the add-on a few days ago and I am so happy about it that I’ve made a 1.5 min video showing my gratitude for your work :smiley:

2 Likes

Thank you, Bracer. I’m so glad you like it. Your video is a great impetus for me to further improve this add-on. Stay tuned, it’s not over yet. :wink:

1 Like