Blendswap fails to upload with "black hole" message

Earlier today I finished one of my models, and decided to upload it on Blendswap. I zipped the file, filled all of the fields, and tried to submit. The file never finishes uploading however, and instead I get a message about… black holes. :spin: It also mentions the URL of the page I was already on and says that it doesn’t exist on the server.

The request has been black-holed

Error: The requested address '/blends/add' was not found on this server.


I assume the site was either hacked by some bored kid, or the admins are very new to this. In either case, does anyone else get this when trying to upload, and knows when it might be fixed or if there’s a workaround? It seems to happen in both Firefox and Konqueror, so it’s not browser dependent.

Yeah I went to upload a model there and get exactly the same as you.

http://www.blendswap.com/help

Blend Swap says “the request was blackholed”

This is not a bug, it is a security measure we use to protect the site. Do not report blackholed requests.

  		Forms on Blend Swap are valid only for half an hour, if your  submission takes longer than this it will fail and you may get a 404  error.
  		This will also happen if you leave a form unattended for more than 30 minutes (say, the comment form) and then submit it.
  		This will also happen if you try to register and have cookies disabled in your browser.
  		If you get the 404 error: go back in your browser and RELOAD the page by hitting CTRL + R or F5 so you get a new, valid form.

Thanks for the clarification. Sadly I’m not sure if that’s currently the case: After the problem first happened, I opened up another web browser, quickly filled in all the fields and tried again… same issue. Why did it still happen, even if I filled the fields on a brand new page in less than a minute? I’ll keep trying and see if anything changes.

[EDIT] Just tried again. After not touching the site for over an hour, I quickly opened it and filled all the fields and submitted. The issue is still there, which really feels like something is broken.

I’d send an email to the admin if you’re experiencing problems like that and let them know. There’s a chance that they don’t know.

Just woke up and tried again today. Filled in the fields very quickly, and same issue. I’ll open a bug report and email them as well.

Hey guys, unfortunately this is not the normal Black-Holed request that is due to an expired link. We’re looking into it to see what could be causing it. Thanks for not flaming us, LOL, I’ll be in touch.
matthew

Hi, guys.

We’re still working on the issue, it seems there’s an issue between two components of the site and they’re messing each other around.

I just did a test and I indeed ended up with the same result. I’ll keep you posted about our progress with this issue.

Hi again!

We managed to fix the issue, it was some server settings that were reset by mistake a few days back when we were trying to deal with other issues. Your files should pass as long as they’re below 90 MB in size, as usual.

Please send us a message from the site if you run into any other issues or if this one in particular happens again.

Cheers, and enjoy the site!

I can confirm that it’s working now, thank you for fixing. Otherwise this was a bit frustrating since the message also seemed pretty gibberish and weird… most websites make it more clear when there’s a problem, and use more common terms (never heard of black holes as a computer term before).

If you use the site frequently you’re supposed to never see a black hole error (unless, as mentioned before, you left a form unattended for a while), this instance of the error was also very frustrating and mysterious for us as well, and it wasn’t until we looked in the server configuration that we realized the source of the problem.

Anyway, I’m glad it’s working now, Keep up the good work. See you around on the site.