BlenRig 5 Public Release

Hi Alex! That doesn’t look bad, now you need to add corrective shapekeys to each pose. You do that with the mouth_corner_L on one side and mouth_corner_R on the other, as the targers of the drivers.

If you take a look at Vincent or Spring, you’ll find those shapekeys, mouth_corner_out_L, mouth_corner_up_L, etc.

On the other hand, if you want to do it the dirty way, you could also add a corrective smooth modifier and use a vertex group to define its influence on that area.

Ooooor, you could use both methods for a super good final result, hehe.

I’m glad that not everything is so bad and I can fix it. Corrective smooth can slow down the work with the character in the viewport?

Ha! Anything can slow down the work, but Corrective Smooth is not that bad, maybe it can take around 5 fps, but it’s definitely worth it. If your rig is really slow because your CPU is not good enough, you could also turn it off for the viewport and just leave for render… Or you could add a driver with a property that turns it on and off at will.

So it all depends on your CPU… I had a 9 years old i7 and normally BlenRig rigs ran at 20 to 30 fps. Now I have a new Ryzen and I get more than double the speed.

Hi,

I’m new to blender and blenrig in general and have been following the tutorials on Blender Cloud. I can’t seem to find the option to show the mesh deform cage in blender 2.83. I must be overlooking something but I’ve looked for a while and couldn’t find it.

1 Like

Never mind I got it.

Yes, it’s a bug, I’m working on a new version, that’s why I haven’t fixed it in this one

1 Like

hey man how r u … i love this addon … but i try to export vincent or ivan rigs made woth blenrig … they take too long and never work in unreal engine … can u please help me with this issue … i want to c vincent animations in unreal

Hi Ibrahim!

Haha, well you cannot do that because Vincent uses lots of modifiers and things that are not supported during the export process. I’m working on a new version of BlenRig where I will include a game engine preset. But anyway, that won’t help you with Vincent either.

The only way you can export a complex character such as vincent is to export an alembic file with his meshes and then import that in Unreal.

Alembic will bake the meshes frame by frame and export and animated mesh.

2 Likes

thanks alot man … but its a very nice rig … keep up the good work

Good day! First of all i wanted to thank you for such an amazing rig system, it is such an quality gift to a whole blender community. I have rigged the character body with significant changes to the density of the cage since proportions of the character is very unusual (very tall) and i do not have a good result with hands and legs no matter how accurately i mapped default mdef cage, but happily i overcome that problem. However upon revisiting the face which on first pass i deemed as “good” now look… weird to me. My character is a realistic type (not exactly in proportions but overall style), i don’t know how to properly explain, it’s seems that reach the “uncanny valley” effect. Mouth opens and corners moves too much. Mouth upper corners movement looks unnatural and smile looks goofy, when upper part of the lip moves too much. There weird behaviour (or at least it looks like) from bendy bones, when lips are closing in. Also for some reason corner def bone weirdly was popping out so i needed to manually adjust it after binding. Fix joints function do not solved anything. Mind you, im completely examined your tutorial (which is great) and used all techiques as described: Skinned with no autonormalize, overlapping the weights against horizontal and vertical def bones, adjusted actions so mouth moves more naturally (like when corners moves in closer to the jaw). I even examine Vincent character, removing all smoothing and drivers to understand and know what exactly should i paint. Setup corrective smooth, technique of blending smooth groupes and paint them accordingly. But still overall result is far from pleasant, which i understand that it 100% might be my fault. Im spended like 3 weeks on overall face only and i just kinda dissapointed with bendy bones, especially when it’s advertised as easy to use, to the point when this in this https://youtu.be/4iBkwVQHRzA?t=570 tutorial which is just using positioned bones with automatic weights looking better and realistic, so i just thought to abolished it all together and start from scratch using standart approach of bones+shapekeys.

Maybe im looking in wrong direction, can you please help me to understand what i did wrong? Does this system not suitable for realistic characters with not so much exaragated mouth movements? I already adjusted actions and constraint to fit realistic character. I will link cleaned blend. file if you wish to look, for some reason despite all cleaning it is still too big so i loaded it to another host. https://gofile.io/d/QvUckI

Yo @jpbouza what am i doing wrong, while i m in reproportion mode only the Master torso bone is working other bones seems no to work like in your video -> https://youtu.be/JghyA1GAqr0?t=208

Here is a gif of me trying

Hi @erickBlender! Well, but you have not enabled reproportion mode, you have to press the reproportion button in the Rigging and Baking tab you have there at the bottom.

Hi @GreatOwl!

ok, the problem you have there is that you have not configured the mouth_corner_in action properly. In that action you have to manually move all the lip action controllers to narrow the lips. You haven’t done that and that’s why only the corner of the lip moves and the rest of the lip doesn’t follow.

Also, in the file you sent, you had some of the actions controllers moved out of the rest position. So enable ALL the armature layers from the armature panel, select all the bones and reset all transformrs with Alt+G, Alt+R and Alt+S…

1 Like

Thanks :slight_smile: yes indeed it was the problem.

Starting with Blender-2.83.3, the Fix Joints, Calc Rolls and Custom Aligns functions do not work correctly. To reproduce the error: add BlenRig to the scene, go to Reproportion mode, activate Fix Joints, then Calc Rolls - get a broken armature. In Blender-2.82a these functions work fine.

1 Like

Hi @jpbouza and thanks for your wonderful work. I’ve been using Blenrig in a production character and it’s such a powerful way to work.
Unfortunately trying to rig another character now in 2.83 I’m getting errors trying to bake the deform cage. I’ve got the latest version of Blenrig afaik, and I’ve tried loading the rig back into 2.80, 2.81, 2.82 and have more or less the same problem. I’ve checked that the lattice collection is enabled before baking. Do you have a sense of whether this will be fixed in the next version, or when an update might land? Unfortunately I can’t see a practical way around this for now, and will probably have to use a different rigging system. Noooo! :sob:
I’m on Mac 10.13.6 btw

Hi @Hammers, does that happen with the version from gitlab?

Hi @jpbouza Yes it sure does, v 1.04 I’ve just redownloaded and reinstalled to be sure. I may have a workaround if I make a new Blenrig setup in 2.79, import the reproportion pose from 2.83, do the initial bakes in 2.79 before reappending it all back into 2.83. But I haven’t made it all the way through this process yet to confirm. Let me know if I can do anything else to narrow things down. I’ve also just tested after disabling all my User addons to see if there was a conflict there, but that didn’t help either. Thanks for the follow up!

P.S. I was also curious, for a character which doesn’t need the facial controls, what is the best time in the process to remove those? Just wait until after baking the rig? Cheers.

EDIT: Another workaround I just found…manually copying the Armature modifiers on the meshdeform cage and proxy mesh, and applying one of each seems to have done what the baking would have. I think. In case anyone else is having this issue. Though I’m still having issues with Calc Rolls after trying this.