BlenRig rig is OK on Windows but messed up on Linux

In this thread, I wanted to change some of the bone rotation types in my BlenRig rig from ZXY Euler to Quaternions. That thread helped me do that, but later on I changed my mind and wanted to go back to ZXY Euler. I set the ROT_MODE Properties back to 5 – its original value.

I changed the ROT_MODE Properties for these four bones from 0 and then back to 5: arm_fk_L, forearm_fk_L, arm_fk_R, and forearm_fk_R.

Normally, I’m working on a Windows system with BlenRig installed as an add-on. Everything appears to work correctly, and I can render the animation fine locally. However, when I run this same .blend file on a Linux system (BlenRig is not installed), all of the bones render correctly except for those four bones mentioned above. It seems that I broke something in changing the ROT_MODE.

For example, here’s how it looks on Windows. Notice the “bendy” arm that I’ve circled in red.

Here’s the exact same frame on Linux. Notice how that same bones on the same arm – during the same frame – are not being bent at all:

(hand_L_fk and hand_R_fk are being bent/animated properly – I didn’t change the rotation properties for those two bones.)

Here’s my Blender file:

I’m really stuck with this. I don’t want to redo the animation I’ve done so far, but I also really want to render on Linux – without having to install BlenRig. (I’m rendering in the cloud via AWS with Brenda.) Any ideas on what’s broken here?


OK, I figured out the problem. I needed to go into the User Options, then the File panel, and enable the “Auto Execution : Auto Run Python Scripts” checkbox.