Blocky VDB artefacts when combine with principle volume system?

I notice when i have a VDB volumetric sequence inside a standard blender principle volume / cube setup, this renders with large blocky artefacts that only appear when the principle volume is active. Ie if i render the VDB by itself, its fine, no blocky artefacts.

Two volumetric systems; one is the typical cube with a principle volume shader; nothing special. The second system is a VDB sequence with a principle volume shader. The second VDB system is inside the cube. ie; a steam vent inside a misty environment.

Anyone experience this?

Increased the exposure quite a bit, but you can see the blocks to the right.

I’m using Embergen to generate the VDB, however ive seen this with other sequences from Houdini. Its not a resolution issue. Like i say above, works fine when rendering the VDB by itself.

Rendering with Cycles.

It seems like layering multiple atmospheric systems over each other causes this issue maybe.

Thank you!

Are the .vdb sequences rescaled? Because I have seen artifacts when rescaled .vdb objects overlap with each other. As far as I know, it’s a limitation or bug in Cycles.

Yup, i had to scale down to 00.1 I just scaled back to 1.0 and sure enough i dont see any blocks, so that might be the solution. However that doesn’t solve my issues that i need the VDB to be much smaller lol … and i cant scale up the scene itself due to rigging, characters etc … :slight_smile: Any further suggestions?

I did a bit of testing and I think I have a solution.

Go to the volume settings on the vdb object. You will see a “space” setting. Change it from object to world.

At least, it seems to work in my little test.

Ok will try later this evening. Just adding the scene / VDB for reference:

It seems to work in your scene too. After changing the setting, the .vdb’s density is a bit different and needs to be readjusted, but the blocky borders are removed. Well, the area where the glitches were is a bit noisier than it would normally be, but it’s only noise and looks like it will fully resolve.

Hey, I just tried and yup, you’re right, that seems to solve the problem! That said, i recall some video a while ago saying not to use world space, though i don’t recall quite why that was. Curious if this will bite me in the ass at some point later! :slight_smile:

Thanks again.

1 Like

A bit of research tells me that world space volumes will change in density depending on how you scale them. Object space ensures your volume keeps the same look no matter its size (but seems like it can cause a clash between different volumes, because they don’t exist together in the same space).