Blue area when rendering transparent object (diamond)

Well I’m trying to render a diamond i made (not a very good one but w/e =P) and each time I render it I keep getting a blue area where the 2 planes in the back meet. I’ve tried changing the camera angles as well as the lighting, but it doesnt go away =( so I wanna know if any one here can help solve my problem.

If anything else requires viewing i can screen cap it and post it


Hie, (sorry for my english)
if you have ray mirror enable on your diamonds’ material, it’s may be the reflexion of the skye.
Try to change the skye color and rerender.

I’m thinking that’s occurring because your diamond is not totally enclosed, i.e, it’s reflecting the world colour that’s behind your camera. I could be wrong, but that may be the problem. Try putting your scene inside a cube and flipping the normals of the cube, and then move the lighting to the inside of the cube (if it’s not already).