Bluescreen shadow on object

I have a scene shot with a bluescreen. I want to place the clip, with the blue removed, in front of a wall created in Blender, so the clip will cast an appropriate shadow on the wall.

At the moment I have the movie clip on a flat plane in front of the camera, with the wall a short distance behind it (the wall was just a plane with a texture). The plane and wall are on separate render layers. In the compositor I added a channel key to the plane render layer and successfully removed all the blue, then I used AlphaOver to combine both render layers. However when rendering, the wall behind the clip does not show at all - the background is completely black (ie it shows the clip the same as with the bluescreen, except it’s a ‘blackscreen’

I’m pretty new to Blender, so don’t really have much of an idea what else I needed to do. I tried things like turning off sky and setting the wall shadow to receive transparent but they didn’t work.

Any ideas on what I’m doing wrong? (using Blender 2.56)

Maybe you could add a screenshot of the clip and your node setup to your post. Its really hard to figure out what you want to do from the description alone.

I’ve attached an image that shows my setup in the compositor. It shows what I’m currently getting when I render:


In Gimp I did a quick mockup of what I’d like to get:

Any help much appreciated.

The wall texture only shows as black in blender, but it’s the same as in the mockup.

the node is not finding the render layer. do you have the correct layer selected ? maybe you gotta render that layer / select it and f12 then it will show in the node. Here is a old 2.49 screen shot. It looks a little different .


Selecting and rendering just the back layer gives a black screen. Moving the car plane away from in front of the wall plane still gives a completely black render (same if I move the wall plane away so there’s nothing in front of the camera). But if I set the wall’s shading to shadeless it renders fine, with the wall showing behind the car, except now it doesn’t receive any shadows from the car.:confused:

I don’t know much about Blender, still new to it, so the only thing I can think of is to list every step I’ve done so far. Maybe someone can see where my mistake(s) are.

The bluescreen image and texture I use:


Steps done in the 3d view:
1- Load factory settings.
2- Set camera position to x=0,y=0,z=6 and rotation to 0,0,0.
3- Delete default cube.
4- Create plane at 0,0,-1, and scale till it is larger than the camera view (this is the wall plane).
5- Create plane at 0,0,0. Set scale in object panel to x=1.920, y=1.080, z=1.000 then use s hotkey to scale till it fills the camera (this is the bluescreen plane).
6- Create new material and texture for wall plane. Set texture as image (and open the image).
7- For wall plane material enable Shadow>>Receive Transparent.
8- Create new material and texture for bluescreen plane. Set texture as image sequence (and open the image, set number of frames, etc).
9- For bluescreen plane texture set Image Mapping>>Clip and enable Influence>>Alp:1.000.
10- For bluescreen plane material set Shading>>Shadeless and enable Transparency with alpha 0.000.
11- Move wall plane to layer 2, then select both later 1 and 2.
12- In the render panel make a new render layer, and name them Bluescreen and Wall respectively.
13- Enable only layer 1 for Bluescreen render layer and layer 2 for Wall render layer.
14- Disable Layers>>Sky.

The 3d view at this stage:


Rendering at this stage gave just the bluescreen picture. Selecting the wall layer and rendering gave a completely black output.

My node set up is below:


Am I doing anything wrong or was there something I should have done but missed?

Found the problem! in the render panel I needed to set shading>>alpha to premultiplied.