Blur only on a mesh?

Hi,

How could I add a blur only on the drop of water ? I am starting with the nodes, I could only add a blur on the entire image, would you have any advice for me?


Thanks a lot

Let me give you a starting point. If you have more specific questions, please ask.
If it’s just a still the easiest way would be to mask it out using blender’s masks.
Then use this mask as factor for blur node or as determinator for bilateral blur.
If it’s an animation, you could create ID for this object, activate Object ID pass and use ID mask node to determine factor or determinator. You could also set render layers properly and use them for this purpose.
Anyway, first step is to separate the object and then do whatever you like with it.

I know I didn’t give a step by step solution, but maybe some sentences will lead you to the proper direction.

Thanks! Can you tell me how you would properly set the ID node to the object? I don’t really understand the example from the wiki (how to get indexOB in the Render node, how to get a result with the nodes, the source: http://wiki.blender.org/index.php/Doc:2.4/Manual/Composite_Nodes/Types/Convertor#ID_Mask_Node ), here is my attempt (I already set the mesh of the water with an index of 1 in the object settings) :


Thanks again

You are trying to extract ID mask data from the wrong render pass. Enable “Object Index” under layers in your render settings and use that output instead.

Woah woah woah, why not just use vector blur? Wouldn’t that work better? It shouldn’t blur your image just the drop.

Thanks, if I only use the blur node, I have got the image in black and white, and with multiply, the blur effect goes behind the image, would you know how to get a real blur on the drop? I have tried with “Vector Blur”, but I am doing something wrong, because the image is not showing?1/ with the “blur” node :
2/ with the “vector blur” node :
Thanks again

Any idea?
Thanks

That’s not how you use the vector blur node. You need to make sure the drop is actually animated, then enable the vector pass, attach that to the “speed” input, your z-buffer to the z-input, and your main image/beauty pass to the “image” input. (you wouldn’t need the object ID mask in this case, since that mask is effectively “built in” on the vector pass)

Thank you very much J_the_Ninja, it works, it is not perfect though, but maybe it is fine (the blur is set to the maximum) :


Maybe if you know about the simple “blur” node, and how to mix it correctly with the original image, it would be great, thanks anyway for your help :slight_smile: