Blurry EEVEE hdr?

In recent versions(I’m on 2.81) the hdr background is always completely blurred and there doesn’t seem to be a way to not have it blurred. Earlier versions of EEVEE in 2.80 and Cycles, currently, don’t have this issue. Anyone know why that is or a way to solve it? Cheers.

Are you in lookdev mode or what?

I have 2.8RC3 and lower res hdri’s are always blurry…always have been. If I want a sharper one I have to increase the resolution… a 8000x4000 exr is a lot sharper than a 2k hdri…I am not sure if .exr’s will always be sharper or not. Besides increasing the resolution… there is nothing I know of to sharpen them.

If you are in lookdev mode, is intended. (most likely due to the nature of how enviromental lights are handled in GPU’s). If this happens in EEVEE or Cycles, then there’s something misconfigured, and a .blend file will help track where the problem is.

I always use 8k hdri but beware not to add more than 10 in your world folder or else it will eat your 16GB of ram away and it is painfully slow to load them.

What i do now is testing with 2k and when i have set my choice i load the final 8k version.

This is as I expected. In Toolbag and Substance(or any other modern real-time engine PBR IBL) there is a slider to blur the background. This seems like it’s hardcoded in lookdev. Confirmed in this thread

This isn’t the issue. It’s The same with my custom high res hdrs and this wasn’t happening in EEVEE render mode in earlier 2.80. It’s also fine in Cycles.

Yes, I’ve zipped my configs and it’s still happening with a factory reset and default 2.81?

1 Like

Here’s a default factory reset scene.



Thanks, but this isn’t to do with low quality hdrs being blurry, it’s about Evee rendering the hdr in render view the same as it does in material preview(lookdev) It should be rendering it exactly the same as Cycles in the images above.

Maybe put the hdri as a world background and tick “Scene World”? Workaround, but, well, works.

Thanks, I tried that and it works, but it’s not ideal as it defeats the purpose of having quick access through the viewport dropdown. The frustrating thing is that it worked in earlier versions on 2.80 so I’m just trying to see if anyone else can confirm on recent 2.81 so I don’t think I’m going insane… :smiley:

You’re not going insane. 2.82 doesn’t render the background at all, by the way :rofl:

Really? So it doesn’t even show in Cycles in 2.82? Well, as frustrating as it is, at least I won’t spend the next few hours trying to fix something that can’t be fixed. :laughing: It must be hardcoded in in Eevee render view now the same as it’s always been in material preview(lookdev)

Hopefully this will be fixed sooner rather than later.

Then you may need to report it. (well… you have the files :slight_smile: )

Then that makes it a regression which can be reported to the tracker as a bug.

Yes, I’ve just checked in a 7th July version of 2.80 and it must be something to do with the hdr thumbnail dropdowns that were recently added in 2.81. I will report as a bug. :+1:

Edit: I’ve posted it on devtalk as it’s not really a bug per-say. Is this the best place to post it, or rightclickselect. I’m still a relative new user so I’m not sure what’s what. There appears to be 3 other sites than this that are more dev related.

Edit 2: just confirmed on rightclickselect. It’s hard-coded.