Blurry nebulae (Principled Volume)

Hi guys,

I’ve already asked this question elsewhere, but no-one were able to answer this.

I have a cube, textured with a simple node setup used to create nebulaes.

My camera is flying through multiple cubes, particle systems and volumetric smoke.

The thing is, I can’t figure out why my nebulaes remains blurry.

This is a draft but here it is :

I tried to :

  • Disable Bloom, SSR, AO
  • Increase Volumetric Samples, distribution, lower Tile size (2px)
  • Increase render samples
  • Disable DoF in render AND camera settings
  • Make sure the volumetrics begins at .01 and ends far away (like 10k meters)
  • Highlight the edges of my nebulaes thanks to a color ramp and a subtrack node just before the density input of the Principled Volume BSDF. That way I can have sharpy edges, but it is not what I want, and it is not fixing the blurry issue.

I’m running out of ideas. Instead of spamming images on this post, here’s a simplified blend file (just a cube with the nebulae texture, and a camera). I’ll be glad if anyone could take a look at this. Maybe the answer is a dumb setting to tweak, I hope so, I just can’t figure it out.
.blendfile :

I hoooope that someone will help me, thanks in advance

Bye guys :slight_smile:

Any idea ? Still stuck here :frowning:
It is very likely that my node setup creates this blurry effect, but I just don’t understand why

Hi Pdhm,
nothing changed, loaded the Blend and pressed Render.
And this is the Result.

I am on Blender 2.92

Yes, same for me at home, doesn’t that seems blurry to you ?
And as you “zoom in”, by flying through the texture with your camera, it becomes even more blurry

No, it looks normal to me.

You have Motion Blur enabled.

Okay :confused:
I’m not disturbed by the motion blur, disabling it does not make the blurry render disappear. The texture itself lacks of pointiness.

It seems that this is a normal Eevee render, I’ll just have to wait for an upgrade of volumetrics in Eevee :confused: