Blurry particles

I’ve searched and followed every static particle tutorial as best as I can. There seems to be something changed between the blender version I use, and the ones that the tutorials used, as it simply doesn’t work for me.

http://img.photobucket.com/albums/v91/exabyte256/looksee.gif

See the problem? It’s supposed to have a white strand sprouting from each vertex. Instead it looks like a blur. I’ve tried adding materials to it, but that only changes the blur’s apperance rather than getting rid of it. Where’s the setting to disable this annoying thing?

The new hair tutorials use Blender 2.40 RC1 and you’re using 2.37. The new version is stiull a beta, but work very fine. You can download it from www.blender3d.org.

Ah, that definately solved it! Thanks.