Blurry texture problem

Hi I am working on a game that looks like a ink sketch, but I’m having a problem with the clarity of textures at savere angles from the camera.



Dose anyone know a way to fix this , or is it just a something we have to put up with the wya blender renders stuff in game?

heres more a little more info on the project

Thanx for any help
Wallmasterr

You can try upping the graphics texture quality in your graphics card settings. Also, make sure your textures are sized by powers of 2 (i.e. 128x128, 256x256, 512x64, etc). You could also try sizing them up.

Thanx i think that did th trick , i tryed uping the texture size first but no difference. then turned up the 3d quality on ati graphics card,(never touched it before :P), didint work at first but it did after a blender restart.



Also scaled the uv down a lttle as on the lower box i might have been pushing the lod to much still a test scene at the moment itl look pritty soon. :smiley:

Blurriness at extreme angles is an artifact of mipmapping. To solve this, you can use anisotropic filtering in addition to mipmapping. You can find options for anisotropic filtering in the System tab of the User Preferences; I recommend 4x.

Anisotropic filtering is the one you want. As for texture sizing, I believe if your texture size is not a power of two the game engine will scale it up until it is. Might as well make it that way in the first place so you get to use all the texture space available to you.

As of 2.64, this is no longer a problem. If you supply a non-power-of-two texture, Blender/BGE will only scale the texture if the graphics card/driver does not properly support non-power-of-two textures.

Ah! Good to know. If I’m not mistaken power of two textures are still more efficiently handled by most video cards, but it’s nice to have the option to size a texture exactly as you see fit if you want.