blurry tile sheets

So ive made a tile sheet in photoshop witch is 256 x 256 or something like that

and each box or individual tile is 16 x 16 basically just like minecraft but when i add the tilesheet texture to a object in blender then scale the uv to focus on a individual box the texture on the object becomes very blurry.

Is it that 16 x 16 is just to small?

SolarLune always answers this, it’s something like mit-map I think.

oh ok i will try that thanks

EDIT: also do you know or any know if having tilesets will increase performance over just having individual textures for each object?

Only a small memory gain. I would have separate ones.
BTW, it’s mipmaps under the texture setting I’m pretty sure.

Ha, Solar answered me about this question too. The only problem with switching it off is that I don’t think it will be off in the runtime file

Like cam.dudes said, mip-maps won’t be off in the runtime.

  1. I made a preloader to restart the game with mip-maps disabled - it’s a scene, which means that it’s cross-platform friendly. It’s not that great to see the game restart, but it’s not that bad.

  2. If you don’t want to disable mip-maps, then you’ll need to scale up the texture with no interpolation to make it crisp (i.e. 64x64 tiles instead of 16x16 tiles).

  3. Martinsh and mokazon’s Candy branch allowed you to switch off interpolation, which I think gives the same results as no mip-maps, but should work in the run-time the same as Blender. Hopefully that (and their other additions) will make it into trunk soon.

  4. Mip-maps actually speed up running the game, as far as I can tell. While it’s not apparent for single-texture or multi-texture modes (I guess; I use Single-texture mode for my 2D / Pixel games), in GLSL mode, your game can really run slowly with mip-maps off. So, if you’re going for chunky pixels and GLSL mode, then you might do better just sizing up your textures.

Ok so i tried the tilesheet again this time witch each individual box as 64 x 64 but it still does the same thing, i didnt seam to even make the textures even a little less blurry. the total size of the tilesheet png is 384 x384

The problem is now with your total size of tile sheet. 384 is not a power of 2, so Blender is scaling the texture when the scene is converted.

Try 512x512. It’s okay to leave blank space on the sheet. It gives you room to add more stuff later :slight_smile:

@blendozo oh ya i didnt think about that for some reason i was thinking it was.

I also removed the minmaping and used 16x16 textures and it works great! it didnt slow the game down any that i can tell.

Well, it should run quiker now. :slight_smile: But does it work as runtime?

eh i forgot about that ill try it.

ok ya it doesnt work in the runtime