blury textures

I’ve modeled a room which I have textured with a 1640x812 jpeg but when I’m standing at the door the texture on the wall at the opposite end of the room looks blury and out of focus,it becomes sharper when I get closer,am I leaving out something how do I remedy this

I’m working in glsl mode

This is because of something called mip-mapping. Currently, it cannot be toggled per-texture, but it can be turned off entirely. Go to ‘user preferences’ (ctrl + alt + u) > ‘system’ and uncheck the box labeled ‘mip maps’.

What da ya know?,thanx longnose.

I think that it’s best to increase the quality of your mipmap settings on your graphics card, as this will disable mip-mapping all throughout the game and create some really bad looking textures at a distance.

I believe the true answer to this question is anisotropic filtering. This smooths out the transition between mipmap levels making them look at less ugly. Currently the BGE does not support anisotropic filtering, but there is a patch created by Moguri out there that adds support for it.