BMRT shaders question

Hmmmm. I don’t know if anyone here uses BMRT anymore, but I’ll give this one a shot.
I am using the RhinoMan plugin for BMRT. I can render my scenes in Rhino, Flamingo (raytracer plugin), and Flamingo Photometric.
I switch to the Rhinoman plugin, and none of my lights work…all of my materials are black. I have tried editing both with no results.
Here is the part that confuses me. Included with the RhinoMan plugin, were some light shaders. I have tried to apply those shaders to the lights. Didn’t work. I applied them to objects…and still nothing. The question that I am trying to ask, is, what are these light shaders for then…?
Rhino has been my favorite nurbs modeler for quite some time, I would like to use BMRT with it…instead of waiting forever for the photometrics and radiosity to work out with Flamingo.

So I am guessing that no one is familiar with the power of BMRT ?

I still use BMRT a bit, but I don’t have any experience with Rhinoceros and the RhinoMan plug-in. (Only with Houdini, Rhinoceros 1.1 [without the plug-in you’re refering too, just the RIB export], LightWave and by manually writing RIB’s.)

BUT, what I think the problem is… is that BMRT uses a different lighting model. Is there a way to export RIB’s from Rhinoceros with RhinoMan? If so, crank up the spotlight values or change the interpolation. That used to work for me when I was using Rhinoceros and BMRT…

I’ve been using Rhino 2 and Rhinoman for a few weeks now with no problem. The lights work just fine. You can substitute the rhino standard lights with the light shaders included with rhinoman - they give you more control, but you don’t have to. I haven’t tried switching from Flamingo materials to BMRT materials, though - I’d say the problem is more likely there. Have you set up your materials and everything properly? Does your render window look completely black? It could be that you need to change your render window setting to/from framebuffer… If you need more help, there is a bmrt group on yahoo, or write to news://


I was setting up Flamingo lights (from the toolbar), and trying to switch over to the Rhinoman plugin. I am now setting up the standard lights and editing them with the F3 function.

maybe you can give me the scene, i’ll check it for you. :smiley: