BodyParts3D objects - issues with exporting to .stl

Hi everybody,
newbie question…

I am trying to build a model of a larynx from individual objects from the BodyParts3D database. Importing the individual objects places them correctly relative to each other so that I can eventually build what I want from the individual parts. The goal is to end up with a model that will be 3d printed. So far so good.
But they seem to be placed in a position relative to a whole human body that would have its heels situated at the origin point of the grid.

  1. problem: I could not move the individual objects closer to the origin. I tried selecting the objects and then snap to cursor. They wouldn’t budge.

So I decided not to bother and continue my modelling where the objects appeared in space because only their relative positions are important and not their absolute position.

A first attempt at sending the object to the slicer yielded a somewhat peculiar result. The .stl file contained all the empty space to have the whole body in it and thus the slicer scaled my precious larynx to the size of a rice grain.

I assume I missed something simple and fundamental here.

I would appreciate any help in fixing this in a way that I can eventually use the model as a basis for further modifications to it.

Thanks in advance for the help
Hansjoerg

P.S. I wanted to attach the file, but due to my limited competence it got enormous, so there’s definitely something wrong here

Snap to cursor snaps the origin of the object to the cursor.
The origin of your objects is probably at 0/0/0 and your cursor is probably at 0/0/0 as well. That is why nothing happens.

The scaling to the size of a rice grain might be because your object is scaled and you´d have to apply the scale. Or your scene uses different scale than your slicer. In the latter case you could either set your units scale to something better or you could set the scale when exporting to stl

Quite frankly it would probably make sense to go through a couple of beginner tutorials and read the manual.
Besides the manual a good starting point is blender youtube channel where you can find a bunch of “fundamentals” videos.

Hi Lumpengnom,

thanks for your reply.

Regarding the origin, the answer was obviously already in my question, so thanks again for pointing it out. Much appreciated! (definitely no irony here!)

Regarding the scaling issue I was probably a wee bit unclear. The down scaling happened in the slicer because the .stl file somehow contained a large amount of “empty” space.

This is most likely the most polite way of writing “RTFM” I’ve come across so far :joy: that truly made my day!
And trust me I did my manual reading and Fundamentals video watching. In this case I couldn’t connect anything to my specific problem Although I am new to blender, I am not new to the interweb and it’s fundamental rules of politeness.

Anyhow, by starting from scratch again I seem to have avoided some of the above issues and got a few steps further. Unfortunately not without encountering some similar issues.

If I may be so bold to raise them in this post:

The original object consists of a single layer of faces without any “thickness” to them. Hence, after some manual reading, I deemed the “solidify” tool to be appropriate. After applying this said tool vertices appear out of nowhere generating spikes from the actual model going into the distance. Some of those vertices were easy to select and delete so the spikes went away. But some disappear into the far distance and neither edge nor vertex select let me address them.
As the outside shape of the object is important for the relationship with other objects I can only solidify inwards (negative value). The higher the number gets the more spikes and the farther away the new vertices appear.

Thanks again for any help.
Cheers
Hansjoerg

Could you upload a sample? Either here or e.g. on pasteall.org/blend/ posting a link here? Depending on how far they disappear into there might be a bug to report (or this may just be the consequence of your concrete geometry).

As for getting rid of them, you can use x-ray mode and box-select everything that you actually need, then invert selection and delete the rest. Also, you may try a couple settings on the Solidify modifier, the Even Thickness and Normals -> High Quality. The latter especially can help in some cases of such spikes.

There are several reasons why your geometry might have spiked. But we’d need to see the file or at least some images of the problem.

Depending on the object you do not need to solidify and might make the problem worse. The slicer will usually take care of that.
But in order to be able to do its job the slicer will need the mesh to be set up in a correct way. For example there can not be non-manifold geometry like open edges for example or edges with more than two polygons.
Blender can check a couple of problems for you.
In edit mode -> edge mode you can check for non-manifold geometry under
select -> select all by trait -> non-manifold

You can also activate an addon that comes with Blender under
Preferences -> Add-ons -> type printing into search box -> check box for “Mesh: 3D-Print Toolbox”
After activating it is located in the N-Panel while in edit mode.

1 Like

Good Morning,
I didn’t work on the model over the weekend, hence the late reply. First of all, thank you so much again for helping me.

trachea_straight_lower.blend (951.8 KB)

This is a version with the spikes. It happened with one step of the solidify tool, using a -.6m distance for the tool. In my previous attempts I was using the tool multiple times on the already solidified mesh which gave more extreme results.

I have done pretty much that, solidified, identified the offending vertices and deleted them. This gave me a version of acceptable quality to work with. But tbh I would like to learn and understand what happened to try and avoid it in the future.

That was my initial hope, but at least the PrusaSlic3r completely ignored that part of the mesh and didn’t do anything. Only once I started do solidify the object it started to generate some useful code. I had to solidify up to about 4 layer thicknesses to get a printable result.

Back to school for me, I have to find a “complete idiot” level tutorial that explains those concepts…

Thanks again guys!
Cheers
Hansjoerg

Starting with that file:

  • Select -> Select More/Less -> More
  • Delete faces
  • Select everything, Mesh -> Merge -> By Distance
  • With everything still selected, Edge -> Clear Sharp
  • With everything still selected, Mesh -> Normals -> Recalculate Outside
  • Go into object mode, in the properties editor on the right find Object Data Properties (green triangle) and under Geometry Data there click ‘Clear Custom Split Normals Data’

Now adding Solidify shouldn’t produce those artifacts.

Basically, for Solidify to work consistently you need to make sure the normals on the mesh are pointing consistently outside (or inside), i.e. that there aren’t any flipped faces. The custom normals thing you pretty much can ignore if you’re going for slicing/printing, it’s just to make the thing look nicer in the viewport.

There’s another minor issue of an n-gon with a bunch of vertices around it - the face that you’re looking at directly after opening the file. If it causes issues, you may want to dissolve those extra vertices.

You made my day Stan!

If I understood correctly there were faces that had normals pointing in the wrong direction?
Is there a way to find that out from the start or should I simply use your procedure everytime I come across an object where I am not sure which directions the normals are pointing?

And in case I’m starting something from scratch is there a way of avoiding this happening?

Back to building the whole larynx now…

If you have an hour to spare, you may find some useful things here:

Basically, use the face orientation overlay and Select Non-Manifold. They are your friends for identifying a great deal of issues.

I’ve finally managed to get is sorted, thanks again for the help.

But life wouldn’t be if not a new issue would have reared it’s nasty head. Since it is still a problem with exporting to .stl I keep this thread alive.


(I hope this works)

After successfully solidifying the trachea object and adding all the other bits that I wanted in my simplified representation of the larynx I used the objects join tool to have a single object to deal with instead of a collection. First export to .stl and sliced it. Fine, generated a printable version of the object.
Next step was adding the base plate (the larynx will be inserted into a larger model of a neck for medical skills training) and extruding the bottom of the trachea for printability and stability of the model. Then I joined the two objects again. In object mode it looked pretty much exactly like I wanted it to look. So next export and slice…
The part where the base plate and the thyroid cartilage (the larger tent like structure) intersect gets sliced as expected.

But further downwards, where the extruded back part of the trachea intersects it gets sliced as two different things.

Initially I thought it might be because I did two join operations, but this doesn’t seem to be the cause. If so why would one part slice correctly but not the other.

Any good ideas would be appreciated…

Select Non-Manifold (specifically, its Boundary option) identifies a few holes inside the object. Perhaps that’s the problem?

The resulting selection can be difficult to spot since it’s in different places, you may need to use x-ray or wireframe shading to see where it is.