Boids follow channels?

I’ve carved paths in a plane and placed a goal object in the center, my goal is to have the particles follow these channels to the center and accumulate. However instead of following the channels the particles simply cut through the gaps right to the center/goal object totally ignoring the channels I made. I even put avoid objects with collisions enabled but a noticeable some still cut through… So how can I ground the boids to only follow the faces of the emitter… I only have allow land checked

thanks alot