Bold and Italic Fonts?

Hi Folks:

Using Blender version 2.78.

I want to model some bold and italic text.

I’ve been through several YouTube Blender text tutorials by people who demonstrated a bunch of interesting things that can be done with fonts.

Unfortunately, changing text to bold and italic weren’t one of the topics.

This Blender’s reference page says:

To apply the Bold/Italics/Underline attribute to a set of characters, you either turn on Bold / Italics / Underline prior to typing characters, or highlight (select) first and then toggle Bold/Italics/Underline.

Setting bold and italic, then typing displays regular text. Selecting the text and hitting those buttons does nothing.

I can slant the text with the shear value, but I’d like to match the text in the application’s logo.

I’ve tried Arial and Times, no joy.

So I have this:


What more do I need to do to display, and eventually model, the text as bold and italic?

  Thanks
  Larry

Load the fonts you want to use like in the font panel in my first pic below


then, in object mode, select the text object and choose the style from the drop down menu in that same Font panel, like so:


Oh, one other thing, I suggest you tick the “F” button on each font so you don’t lose them when you save and re-load your file:


Thanks Sabba:

That explains font selection, which already works fine for me.

I’m unable to get the text to display with bold and italic.

I composed that question late last night, powered by exhaustion and frustration. I probably wasn’t clear.

The post was being edited as you were writing your response.

Perhaps I did a better job of explaining my situation as the post is now.

I appreciate your response.

Thanks
Larry

Hi

Same here…It do not work…I use daily build…If You use officiel blender…It nay be a bug…?

Tai

Works here. 2.78c. Linux.

Select the fonts for the different font attributes(usually bold, italic, and bold-italic are seperate font files)
The bold/italic check boxes, in the properties panel only affects new text.
To change existing text use the buttons in the T-Panel.


Seems to work fine here…

https://dl.dropboxusercontent.com/u/27650383/03-04-2017%2019-08-34.png

Make sure that the specified fonts actually are “true” bold/italic fonts:
Blender can’t (unlike Word etc.) create virtual italics/boldface from regular fonts.

Also: You can’t check Bold or Italic on existing text and see it change. You will have to check those options first, then type the text.

Thanks everybody:

That’s it.

I do a lot of C++ code with fonts in Windows rich text edit boxes.

I’ve always just selected a type face “Arial” or “Times”, and then selected the bold, italic, or whatever from that.

I somehow missed the different types of fonts in the directory.

Ok, this is like 2 years old, so I don’t know if it’s still relevant for anyone, but here it goes.

I found that after setting up the fonts for regular, bold, etc. I just couldn’t select text in edit mode and apply the style, but I had to enter edit mode, select the desired style and THEN start typing.

Not being able just to copy/paste and apply format was sort of a bump in my workflow, but at least it works.

1 Like