Bone Heat Weighting issue - New model on old armature

Ladies, Gentlemen.

I’ve begun working with 2.59 for some character animation. I’d begun by importing my character model, and then building the armature around it and parented the model to it using Automatic Weights. This went off without a hitch, but I did find a few areas where the model’s topology could be improved.

So I went back to my modeling software and fixed it up, importing the new model into the same scene. It was only then that the “Bone heat weighting: failed to find solution for one or more bones” issue cropped up when I attempted to parent the model to the armature using Automated Weights.

If this isn’t the case, I’ll just look up one of the solutions from others who had experienced this issue, but do you guys think that loading the model after the armature would cause such issues? If so, what could I do?


Twasn’t the case, it seems. All I had to do is re-export the model and it worked out properly. I’m thinking it’s because I used a different method for exporting it than I did originally, so if you’re experiencing this issue, try that out.

New model, same problem.

I’ve imported a second character model and attempted to attach it to the previously used armature. This Bone Heat issue is STILL a problem. What’s with it? How can I solve it?

I’m sort of shooting in the dark here, since I haven’t run into this issue, and do all my modeling in Blender but…

Do your imports have vertex groups already assigned that are preserved in the import? It may be that Blender is trying to find a bone for a vertex group (or groups) that doesn’t exist in the armature, perhaps due to naming issues or some such.

Nah, the Vertex Groups box is empty.

I’m using OBJ format to transfer the model about; Does Blender not like that format, perhaps?

OBJ is very common and afaik Blender has no issues with it, though I haven’t used an OBJ import for binding to an armature yet, so I can’t say for sure.

Have you gone over the imported mesh for issues like doubled verts, non-manifold faces, etc? These sometimes happen on imports, and can maybe glitch the auto-weighting(?)

Man, it’s dark in here, and it’s loud when I shoot! :wink:

Ah, got it! I had some of the mesh’s pieces lacking faces in areas where they wouldn’t matter, but I guess it does with Blender (Kind of inconvenient…). Is that what non-manifold faces are?

Anyway, most of them don’t require deformation, so I can just parent them to the bone they should be on.

Missing faces shouldn’t be an issue because the armature influences vertices, not faces. However, how the OBJ export/import processes such cases may lead to problems with the armature auto-weighting. Hard to be sure without looking at the mesh, but it seems as if you have it solved, right?

Non-manifold faces: "A “Non-Manifold” mesh is a mesh for which an “out” cannot unequivocally be computed. From the Blender point of view, it is a mesh where there are edges belonging to more than two faces. "
– from this Manual page

Hm, I see. Thank’eh, man.