Bone Weight and Vertex Group Issues ;[

EDIT: Whoops, I totally didn’t see that I posted this in the wrong section -_-. So if a mod may could you please move this to the Question and Answer for Animations.


So, yeah I have been scratching my head on this for about an hour or two now. My problem is that no matter how many times I redo the bone weight on one section of a boot the vertices just don’t seem to take. I have never had this issue until I upgraded to the newest version of blender :(. I have even tried using the automated bone heat but yet it doesn’t seem to work either.

See images to see what I mean. The first image is just showing how the weight was painted but as you can see in the second image even though that the weight is set to 1 on those areas it is acting like it is not taking on some vertices.

I have checked and rechecked and there are no extra vertices that I am missing and no extra faces.

Yes, the other areas of the bones are not associated with those vertices at all I have even manually gone in and removed the vertices from the groups and reassigned them but yet still nothing.

So, I am completely stumped >.<



Sorry it’s been a week and nobody’s responded. I hope it’s solved by now, but if not:

Edit mode
‘n’ for transform properties window
Select one vertex that’s not right
Look at the list box in the transform props window - click it and it will show if that vert is assigned to any other vertex groups - even if the weight is 1.0, it’s proportional, so 5 groups all at 1.0 ends up as 0.2 each. Very annoying.

If that’s not it, check the edit buttons for the armature to make sure "envelopes’ is clear.

When redoing weights, delete all the old vertex groups first (object mode, edit buttons, select any vertex group if none is selected (in edit mode) and hit ‘delete’ until they’re gone). Old weight assignments stay around and are hard to fix - even bone heat doesn’t start from scratch.

Hope this helps, happy holidays.

Dave Heinemann

Thanks for trying to help, but like I said I have tried everything. I even just retried what you suggested and still those vertices act like they do not belong to any bone group.

Yes, I deleted, re-deleted, imported the original model that never was changed into a new file, but yet those vertices still will not change.

So, I have changed my plans. I will be using another program to position my model, if it will stop crashing on me lol.

Shift + Left click on the part of the mesh that is being effected while in weightpaint. You will get a list of the bones that that part of the mesh is assigned to. After that it’s a simple matter to select the “bad” bone(s) and paint out it’s/their influence.

Note: you can rotate bones in weight paint mode, or use a test action to make the weight errors visible and easier to repair. That’s wht I did for these screen shots.