Bones are in the right place, but hands aren't


So I just got into blender animation recently. I’m a complete noob and have only done a few animations (mainly gun reloads), but I know the basics.
I was working on this simple pistol reload and making bones for the separate parts of the gun, like the magazine, slide, when my hands that I had rigged earlier just got into the standard position, but the bones stayed where they were.
I guess that there’s a button that I accidentally pressed and it’s just an easy fix, but I couldn’t find anyone that has had the same problem as me.

I’m using Hyper’s rig and the gun model is from CS:GO.

A couple of possibilities here:

  1. You have a Shape Key on the mesh that moves it away from the bones - so check to see if you have any Shape Keys that might be causing the issue.

  2. You may have moved your armature in Edit mode by accident. If this is the case, you should be able to select your armature, go into Edit mode, and reposition it to be in the correct relationship to the mesh, then when you go back to Pose or Object mode, the bones should be in the correct place.

One other possibility that I just thought of: If your mesh or your armature have existing transforms on them, things can get very unpredictable when you start parenting things. A very good habit is to always freeze your transforms on your objects before parenting - or make sure you parent them with their transforms zero’d out (Ctrl-A).

I don’t really know how to add or set a shape key, as I said, I’m a noob, but I don’t think that’s the problem. In edit mode, the arms and bones are straight as they are in edit mode, and when I go back to object or pose mode the bones go to their right place but the arms stay straight.

I think the whole thing began when I tried to copy and then paste a bone in edit mode, the bone connected with the fingers and stuff, but I managed to remove it later. Idk though.

I can’t link the blend file unfortunately, new users apparently can’t upload attachments

A question:
How do you select the hands/arms mesh? I can only select the bones it seems like.

Ah - OK - that helps as I wasn’t sure what you were describing. So , questions: If you move the bones, does the mesh move at all? - i.e. fingers move when you rotate the finger bones? If not, then it’s likely that your mesh isn’t bound to your armature. With the bones moving when you go to Pose/Object mode, it sounds like there is a keyframe on the transforms of the bones.

I can’t see your entire outliner, but I get the impression that your arm mesh isn’t parented to the armature (bones) - so this is likely the issue (no vertex/weight groups). As far as not being able to pick the arm mesh, you need to be in Object mode (not Edit or Pose) - if you are and you still can’t, then picking might be disabled on that mesh. Can you highlight the mesh in the Outliner (pick on the name)? If you can, you can go to the Object Properties tab (the orange square tab) and under Visibility make sure that the box next to “Selectable” is ticked.

Can you upload your file to Dropbox or maybe a bitlocker like MegaUpload and post a link?

When I move the bones the mesh does nothing.
I can’t select the mesh in Object mode, I had tried that a few times already, and I’m not really sure where the mesh is in the Outliner.

Here’s the whole outliner:

And here’s a link to the blend file on Dropbox:

Thanks for the help so far!

In the Outliner display the Selectable icon and make your object selectable again:


then select it, go in the modifier and see its Armature modifier: the armature has been removed so it can’t act on the mesh anymore, so select it back:


There we go!
Thank you so much!
Now I can go back to animating :+1:

Ah - someone beat me to it :slight_smile:

Here is a link to a quick video - but it looks like you already have it working :slight_smile: There is a little more information in the video regarding how Blender sets up it’s meshes for bone animation - things to be aware of - so it’s not a total waste :wink:

1 Like

Wow, you made a whole video for me!
It’s already working but now I understand a bit more of how it works.
Thanks for all the help! :grinning: