Bones have stopped moving mesh even though weight paints are allocated correctly

Hi I’m new to Blender and this forum.

I’ve built this ED209 type robot.
I created an armature, I parented the armature to the mesh with automatic weights.
Then I went in and refined the weight paint so that each bone works with each vertex group.
I followed a rigging tutorial and created a few target bones to work with an inverse kinematic set up to keep the toe level to the floor as it’s lifted.
Then I made a new bone layer and created some some controller bones with drivers to be used to move the leg section of the armature like a puppet.
It all worked really well, and I was super happy with it.
So I moved to the next part and I started on the spine. The first part was disconnecting the inherit location of my lower spine bone so that I can get the shoulders to twist in the opposite way to the hip creating a walk motion between the arms and legs.

This is when something went wrong.
All of a sudden the mesh will not move with the armature in pose mode at all.
I have looked at the weight paint and it is all allocated to the correct bones.
The bones move correctly with each other just how I want.
But the mesh will not move with the armature when I move it in pose mode.
I’ve tried clearing the mesh and armature parent and reapplying the the parent with automatic weights.
I’ve applied scale to the mesh. I’ve merged duplicate vertices. There are no mirror modifiers active on the mesh. I’m totally flummoxed.

I’ve been here for two days now searching to see if other people have had this problem.

Can anyone help?

I’m not sure if I’m allowed to attach a blender file or a screen video that I’ve made but maybe I can once I get a reply from someone.

yours sincerely stuck in rigging quagmire

Hello, please share your file

1 Like

Ok, attached is my robot…
Robot_armeture_bonerolled.blend (4.0 MB)

Actually noticed that the robot is pink with just the Blender file, so attached is the other document that sits next to it. I’m guessing this has some of the assets needed to use the Blender file…
Robot_armeture_bonerolled.blend1 (4.0 MB)

I just realised that my vertex groups, are a mess. “head” has got loads of extra vertices that I don’t want to be in that group and there are two heads. Which is cool in the song by Power Tool in the Bill & Ted film but not so good in my vertex grouping system. I feel I need to sort them out. Could this be part of my problem? The weight paint is all still assigned to the correct bones.

Close the vertex group in the modifier:

You just did it!
Works perfectly now :slight_smile:

Thanks, that’s made my day!


Do you have any advice about the basic structure of my rigging.
Or if you know a good tutorial that covers the stages of rigging?


Hello, actually for objects like robots and all manufactured objects, parenting With Empty Groups is the way to go, then assign the vertices to the vertex groups they should be part of. For organical objects like animals, plants, humans, use With Automatic Weights then correct in Weight Paint mode if necessary. I liked the Darren Lile and Sbastian Lague tutorials on rigging for characters, but they are for 2.7, the interface has changed since, but it should not be a big problem

Brilliant, that makes a lot of sense, I feel like I’m moving in the right direction.
I’ve not cleaned up all my vertex groups now and I’m really enjoying learning about bone constraints.
Thanks for the advice I will defiantly look up Darren Lile and Sebastian Lague.


Sorry, don’t know how I managed to get “not” in there. I meant I’ve cleaned up my vertex groups.
Some times I feel like my fingers play jokes on me :slight_smile: