Bones move waaaaay too fast with ik solver...

Is there a good way to slow down the movement of the bones when using an ik solver? I am trying to create poses and the bones move so fast and get screwed up even with the tiniest movements. I’m also looking into constraining movements of the bones. Are there any good resources that reflect the current version of blender? Suggestions are greatly appreciated.

  • willjm

How are they moving too fast?

Are your bones flipping between two extreme positions? If so, you need to set some degrees-of-freedom settings on the bones in the ik-chain. They’re the lockx/y/z and limitx/y/z buttons in the armature edit panel for each bone.

Aligorith

Sounds like you’ve made some mistakes with your rigging. Tell us more about your armature (or better yet, post a blend) so that we can help you better.

Is there a way to post a .blend file here or do I need to create a link to it? If I have to create a link, I’ll have to wait until later where I am able to do that. I have started taking a look at using the lock and limit buttons.

Ok, here’s the location of my .blend file. I have used the locks and limits only with a couple of the bones in the back legs.

http://www.cs.sunyit.edu/~bodilyw/models/malamute.blend

I had these problems as well. It occurs when incorrect bones are given an IK Solver contraint. Also the IK bones are parented to the joints; these should usually be parented to the top-most bone used to move the whole armature or have no parent at all. You should try setting up your IK chains before adding limits and locking rotation; these are useful once you know the IK solver is working correctly and you would like to restrict the degrees of freedom.

I’ll investigate the blend file a little later to see how the problem can be corrected.

OK. Here’s what I did to make the rig behave well on the left leg (see picture).
[EDIT]Picture with bone names[/EDIT]


  1. In Edit Mode, select all bones and hit CTRL+N to align bone rotations.
  2. In Pose Mode remove IK solver and limits on following bones: UpperLegB.F.L, LowerLegB.F.L.
  3. Clear parent relationship for following bones: IK_lowerleg.F.L, IK_upperleg.F.L.
  4. Select Paw.F.L. Add an IK Solver contraint with following settings:

  5. Select LowerLegA.F.L. Add an IK Solver contraint with following settings:

Now you can move the IK_lowerleg.F.L and IK_upperleg.F.L bones around and you should not have the weird glitchy behaviour. When you have this behaviour, the IK chains aren’t setup properly and you will notice that when you TAB in and out of Pose Mode, the pose will be reset. Once it is fixed, your pose won’t reset when you TAB in and out of Pose Mode (you have to clear the rotation, location and scaling (ALT+R, ALT+G, ALT+S) to do so.

Also, now you can limit the rotation of the necessary bones so the armature doesn’t get into weird contortionist poses :).

This fixes your problem of weird behaviour but the rig for the legs isn’t the greatest for animation; its good for posing. I noticed you have not used null bones at all and that your entire leg is a chain; usually the upper and lower leg will form one connected chain while the foot bones will form a separate connected chain.

Look up some foot rigs like Mancandy, Ludwig and the one in the Blender book. These have been very useful to me.

Hope this helps.

Yes, your help was extremely helpful to me and much appreciated too! My model is now actually manageable which is very cool! I have already applied a good amount of constraints to the model so it doesn’t get all twisted up on itself. I will be sure to check out the references you have listed so I can get better at rigging and animations. Thank you so much Wizard, you rock!

  • willjm