bones not staying connected

afaict both left and right side are the same in bone relationships. But foot.l is not staying attached to calf.l, even though calf.l is parent and the ‘connect’ button is pressed (see red circle). As you can see I don’t have the same problem with foot.r. There is a dotted line from the bone where it should be connected. I can move it manually into place but what a pain. It is acting exacly as if the connected was not pressed.

If you have a CopySomething Constraint on it move it below IK-Solver constraint?


Did you try unparenting the bones then reparenting them making sure to choose"keep connected" option on the prompt menu ?
Quote :"the ‘connect’ button is pressed " - what connect button ? >>> Ok I found it but it’s useless . I just tried your same rig and “disconnected” by unpressing it but the bones still stayed attached ! (maye be you need to exit and reload for Blender to accept the change - otherwise try the above method)

I guess the connect only does something in edit mode. Anyway it seems that Blender can only keep foot.l connected to calf.l, or fclaw.l connected to foot.l, but not both. Strange because I don’t have this problem on the right side, they can all stay connected… I tried exit and restart blender like you said.
Is this a bug in Blender?

Achilles had the same problem.

Could you please post the .blend?


Here it is. I removed the mesh so you’ve only got the bones. If you select ik_foot.r and ik_toe.r and move them (along y axis for instance) it works fine, but if you do the same on the .l side it falls apart. Thanks for looking at it!

Can’t find a reason why the left side doesn’t work, though I admit I didn’t look too hard. Anyhow, you can solve your problem by giving the mtoe constraint a Chainlength of 2 and the fclaw a Chainlength of 4 in the Constraint tab on each side.


You’ve left all the Chainlen paramters at 0 which seems to be causing the problem. When I set them all to 2 (tail to 3), everything works, and the rig also responds much faster.

Leaving the Chainlen’s at 0 might / pobably wil work if some of the bones are not connnected, but all your bones are connected which is probably confusing the armature system.

Also turning off subsurf (interactive display “middle” button) will make the rig respond faster.


Hey that did the trick, thanks! Tho I don’t quite understand why…<<<understand now that I read the last post, thanks!