Book Generator Addon

I don’t think we get any crash files in Windows.


I typed this to command line and hit enter:

C:\Program Files (x86)\Microsoft Visual Studio\2017\Community>C:\Users\filibis\Desktop\Blender_2.79.6.lnk -d

And I enabled your addon, Shift+A > Books Row or Stack , then I got this error:

Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF734BEAC9B
Module  : C:\Program Files\Blender Foundation\blender-2.79.0-git.45c11c1a1bd-windows64\blender.exe

No idea, sorry. Sounds like Windows trouble.

Run blender.exe --debug-all (inside an open console) to see if it would generate anything useful in the terminal.

I tried --debug-all , that gives this:

redo_cb: operator redo Bookmaker Row
DAG_id_tag_update_ex: id=SR3D View Full flag=7
DAG_id_tag_update_ex: id=SRAnimation flag=7
DAG_id_tag_update_ex: id=SRCompositing flag=7
DAG_id_tag_update_ex: id=SRDefault flag=7
DAG_id_tag_update_ex: id=SRGame Logic flag=7
DAG_id_tag_update_ex: id=SRMotion Tracking flag=7
DAG_id_tag_update_ex: id=SRScripting flag=7
DAG_id_tag_update_ex: id=SRUV Editing flag=7
DAG_id_tag_update_ex: id=SRVideo Editing flag=7

ordered
 OBLamp
 OBCamera
DAG_id_tag_update_ex: id=MAbooks_paper flag=0
DAG_id_tag_update_ex: id=MAbooks_paper flag=0
DAG_id_tag_update_ex: id=NTShader Nodetree flag=0
DAG_id_tag_update_ex: id=MAbooks_paper flag=0
DAG_id_tag_update_ex: id=NTShader Nodetree flag=0
DAG_id_tag_update_ex: id=MAbooks_paper flag=0
DAG_id_tag_update_ex: id=NTBooksCoverCommon flag=0
DAG_id_tag_update_ex: id=NTBooksCoverCommon flag=0
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF7C0E72744
Module  : C:\Program Files\Blender Foundation\blender-2.79.0-git.45c11c1a1bd-windows64\blender.exe

Unless you can narrow it down to a particular line in my Python code, that’s not all that helpful.

It seems to have something with the Cycles material setup. Try sticking some debugs in the code to try to isolate it.

Hmm, I’ve started encountering segfaults myself now. I was able to fix them with a small update; see if that helps for you @filibis too.

No, it still crashes same.

I have done an update to use a separate random seed for the material assignments. This way, changing the number of colours doesn’t disturb the arrangement of the books.

Also, is it preferable for the books to be generated as one object, or as separate objects? Currently they are separate objects, but because they are all selected, it is easy to hit CTRL-J to join them into one if that’s what you want.

I have added a “magazine” object type. This means I had to replace the single slider for distributing the probabilities between softcover and hardcover with three separate sliders for controlling the relative frequencies of the three object types.

1 Like

Now updated for Blender 2.8.

9 Likes

Thank you! :slight_smile:

Thanks for the nice addon. Sometimes it’s crashing Blender though, especially when I use the arrows to change value. When I type in values instead crashes are less.

Sweeeeeeet!! Been waiting for this. Thanks!

@Peetie I don’t get crashes on Linux–at least, not in a while. Unless you or somebody else can spot a pattern or otherwise track down the point where the crashes occur, I’m not sure what I can do.

1 Like

I’m trying to use it in 2.78c. My laptop won’t run 2.80 because the Intel graphics chip is unsupported.

I can install it, but when I try to enable it, I get Syntax Error at line 1922

count : bpy.props.IntProperty \
     ^

Syntax Error: Invalid syntax.

I just tried it in 2.80 and 2.81 beta.
I can generate a nice, uniform row of books, but as soon as I change any parameters (except the number of books), it crashes Blender completely.

It’s a pity, because the generated books are a nice shape, and it would save me a lot of time. (A client needs an image of a school library)

[some time later]

Just tried it again. I managed to get a row of books with variations in all dimensions and several different colours. Then when I changed one more setting, it crashed again.
Next time I tried, it wouldn’t even create the basic one book without crashing Blender.
I had to reinstall it to get it to work again, and then it wouldn’t let me adjust the number of books.
The next time, it let me change several parameters before crashing.

BTW, I’m using Windows 10 and have 24Gb RAM. I’m adding the books to a new scene, so memory is not an issue.

[Some time later…]
I found that I can now create rows and stacks of books, but I have to tread carefully.
It crashes most often when clicking the arrow buttons to change the parameters. About 98% of the time it’s ok if I type the values in, but almost always crashes when using the arrow buttons.

For me it works fine bookmaker v1.5 on macOS 10.13.6 & Blender 2.81.16.

Here’s v 1.1.2 for Blender 2.79.
bookmaker_112.py (90.7 KB)
It just might work better.

Any option to use own premade textured books ?

thanks for the answer. good job anyway !