Boolean issues.

This happened in 2.48a (or c?), I upgraded to 2.49a and I’m still having the same issue.

That about explains what happens when I try a boolean operation on the ring I’ve created. ._. It doesn’t happen with other things. I created the ring by making a circle, modifying the points, then spinning it four times (90 degrees each time, default setting), then selecting the beginning/end points and removing the doubles.

Any more info needed, I’ll give if I can.

EDIT: Problem solved a few posts down, was told to recalculate normals. ^^;


ring.blend (161 KB)

Blender’s boolean tool isn’t as powerful as 3ds max for example, but i can’t work out what’s happening :frowning:

Never mind… I cannot get it to work at all!

This is an issue the developers really need to address. This is an essential function of a good 3D program, whether it be a CAD or 3D modeler. In order for Blender to truly compete with the big programs, this needs to be fixed.

Try subdividing the cube a little more.

That is what I originally posted. Doesn’t work. :spin: :confused:

I originally tried it with a more complicated mesh (beveled text changed into a mesh), I used to cube as a clearer example. I’ve read many places that blender’s boolean tool isn’t the best, but for the simple things I need, it normally works… when it doesn’t it does crap like this. XD

I’ve run into this issue a few times in the past, but usually just give up and remake the object nothing will boolean with correctly. That’s not very productive, so I was hoping there was something I was doing wrong. :frowning:


Your normals are messed up. Use CTRL-N to recalculate them and the boolean modifier/operation will work fine.

Oh, thank you!

Yup. That did it! Also, apply the subsurface modifier (press the apply button) and then do the boolean operation and the edges will be cleaner. If you don’t hit apply first, the modifier tries to smooth the new edges and they look wrong.


Or you can use the boolean modifier and make sure it is beneath the subsurf modifier in the stack.

Nope. Tried it. You cannot move the Boolean modifier below the subsurface modifier.