Boolean modifier doesn't cut the mesh

Hello guys,
I’m new to blender and try to get into it since some weeks now. I thought I understood the boolean modifier but obviously I don’t. As you can see in the attached pic I tried to cut the marked “cube” out of the “circle”. I add the modifier to the circle and tell the modifier to cut out (difference) the cube. When I grab the cube and pull it up it is dublicated and one stays in the circle. Same if I add two new cubes to the same session and try to cut one from another. If I open a new session boolean modifier works on the cubes. Has anybody a tip for me which settings I messed up?

Thanks in advance
Best regards
Matthias

Hi, can you post a screenshot of your modifier settings, please?

Hey, thanks for your help in advance.
Herr the screenshot of the settings

After applying this is what I get:

Can you try applying the scale of your objects? That sometimes messes up the algorithm precision.

Here is some small tip that I like to do when I am doing a boolean: Sometimes I will hide the object that is cutting another object to see if the cut was made correctly

Kind of like this:


Make sure the object you want the hole in has the modifier
And after hiding the object like this:

you can see if the cut was made. After it is the way you like it, then you can apply it.

Edit:
Use H and alt-h to hide and un-hide objects

Hey guys, thanks for your tips. Unfortunately I won’t be able to check it today. So do you think the size could be the reason? After having problems with proportional editing (not knowing that you can use the middle mouse wheel to choose the size of the effect (object hat just 5mm radius) I made it real big. I will try tomorrow to shrink everything and will report how it worked.

Have a nice evening.

Best
Matthias

you can also adjust the proportional size afterwards for fine tuning:

It’s really strange… I just tried shrinking and applying scale. And I had to realize that my problem seems to be caused by the mesh that was proportional eddited before or the sizes of the objects in relation to each other. While trying it after shrinking the “cube” was bigger than I need it to be. Then it works (see picture). When I scale it to the size I need it to be I get doubles like before/ nothing is cutted.

Do you scale it in Object mode or in Edit mode?

I’m sorry, I don’t remember in which mode I scaled it. But makes it any difference? I had the problem in the very big scale and I had the same after shrinking.
If you think the issue is caused by the scaling can anybody give me a tip in which scale I should work on the model? When it’s ready it should have 10mm radius. Should I work on it in this scale or should I work on it in bigger scale and shrink it afterwards (or in the slicer software - want to print it on a 3d printer)
Thanks in advance
Matthias

Dimensions and Scale are two different things. After you happy with the dimensions, hit Ctrl+A and apply the scale. Many modifiers have problems with uneven scale.

Edit: Did some testing. Got the same issue with open meshes. So, check if your mesh has holes.