Boolean modifier from solidified bezier curve cause light artifacts and weird transparency

Hello guys,

I’m trying to model a piano, and one of the knobs on it has an ingraved logo on it.
Here’s what it looks like in reality :

So to do this, I used bezier curve, that I extruded and then converted into meshes… Then I used a boolean modifier, but didn’t really get the effect I wanted (here’s a photo with the bezier meshes hidden) :

As you can see, one part is completly absent, and for the rest, there’s weird lightning issues…

Does someone know from what this is coming from?

Could be many things…I would start trying these options:

  • It looks like you also have a bevel modifier. If so check the harden normals option in the bevel modifier
  • recalculate the normals. alt + n —> recalculate outside
  • turn on auto smooth. Its in the properties panel to the right. --> click Object Data Properties, the icon looking like a triangle --> select normals and check the auto smooth.
1 Like

No bevel modifier, just a subsurface one.

It’s the autosmooth option that did it for me, I was surprised how easy it was to fix this issue so fast…

The result when applying auto smooth :

Thanks a lot Erik! You made my headache go away :slight_smile:

1 Like

Glad to hear it solved your problem :slight_smile: