Boolean Modifier--Only Works When It Wants To?

Hey, all.

I’m going through Blender Cookie’s “Creating a 3D Typography Effect in Blender” tutorial, and I’m having some real issues with the initial boolean modifier step. I create the text, convert it to a mesh, clean it up, and position it. Then I select the cube, apply a boolean modifier, choose one of the mesh numbers, then switch it to “Difference” just like in the tutorial. Sometimes it cuts the number out of the front of the cube, other times it just cuts random pieces out, other times the entire cube disappears leaving just the number.

I have no idea why it only seems to work sometimes and not others, even when I follow the exact same steps as in the tutorial. Is there anything in particular I should be looking for?

Ensure you have no double vertices and your face normals are consistent.
For a specific answer be more specific with your question, including screenshots clearly showing the problem and importantly attach or link to an example blend file.

Right. Here’s a blend file on PasteAll. I tried the “2” right off the bat and it’s playing real weird. This was made in Blender 2.65 svn 53320, Windows 7 x64.

You are almost there, you just did not finish the ‘clean up’ task before proceeding to boolean operations.

Try this…
Select your number 0 and add a ReMesh modifier to it.
Set the Octree Depth to 6 and hit Apply.

Now proceed with adding the Boolean modifer and chosing the Cube for the Difference operation.

You can animate the cube to reveal the text/mesh using this technique.

I can’t get that to work either, it seems, but the tutorial said to select the cube, then the boolean modifier, then select the number in the “Object” field.

Imo you need to sort out front facing vertices of the numbers. B-select them in edit mode side view for each number and Sy0; then in object mode align again with front face of the cube. Select Cube, add Bolean modifier to it, set Difference and point to number - as in tutorial.
When vertices are not aligned there is funny thing going on, like you describe.

scale, y, 0 isn’t doing it either.

Am I supposed to apply location/scale/rotation to anything? Was the Boolean Modifier broken by an update or fixed/improved in a recent svn? I can’t believe I’m having this much of a problem with what’s a very simple operation.

Downloaded from buildbot blender r53484; did one more time.
Only number for which ngons are created normally after boolean is “0”; this in turn is one for which it is not possible to make ngon in back. This needs to be done by selecting just half of the faces. For the rest you need to delete what’s in front, then recreate ngons manualy.
Honestly too much hassle to even start using booleans.
And Import images as planes looks like broken here btw too.
So, well, ehrmm… yes… Here’s the result anyways


I downloaded the official 2.65a build and recreated what you’re talking about, but it’s not supposed to work like that. It should just cut a hole in the front–a messy hole, but a hole nonetheless. When the boolean modifier worked for me, that’s exactly what it did, no reconstructive surgery required.

What the hey is going on here…?

If you want to imprint the 0 into the Cube you will need a lot more subdivsions on the cube. I thought you wanted to boolean the number with the cube.

For the record JW does it effortless at 00:13:18 here
As i understand things had changed slightly (supposedly ngon code part) and this front face snapping simply does not work anymore or does but badly.
What does work is make number mesh half stick into Cube, then do boolean modifier on cube set to Difference with digits.


You’re right, that did it. Very odd that vertex snapping trick doesn’t work anymore, but at least now we know. Thanks for your help!