Boolean not working properly


Im new to blender and have created a few things already but having some trouble with the boolean modifier. Im following a tutorial on youtube by blender guru to create an abandoned house but he doesn’t show every single thing so I may have got some steps wrong. I have googled to try solve this but can’t seem to get this one sorted on my own.

I can only add one picture as a new user but here is it in object mode where the siding is all messed up while in edit its fine just not cut into the object nicely here.

Welcome to BA :slight_smile:

Are you sure you have a Boolean modifier? I see an array modifier and a solidify modifier, but no Boolean :slight_smile:

If you do, try switching the solver drop down to Exact or Fast and see if one of those works

Welcome to BA!

The way that siding looks feels like you have an entire second house (minus the roof) in the same place, that grey streaky stuff you see there is called z-fighting. If that is so, Booleans might not seem to work properly, but I am not sure what you are trying to cut/intersect/union here anyway. You can add additional images in comments (fortunately the restriction doesn’t last long anyway if you just spend some time in the forum reading a bunch of posts).

I haven’t done that tutorial but will have a look, so we can dig down on what might be going wrong.

Edit: ah, I see, BG makes the clapboard siding with an array and solidify, then uses the original house to cut the protruding, superfluous clapboard bits off around the roof line. You did that part, yes? It looks like it. The house and the clapboard are in the same place, overlapping, and that’s why you have the z-fighting.

Then he scales the original house up so it’s slightly larger than the clapboard (in Edit mode), and in Object Properties → Viewport Display → Display As chooses “Wire” (he wants it to still be there and easily selectable for some reason that might become clear later – well, while the Boolean isn’t applied it has to remain there anyway). He also excludes it from renders.

I think that might be all you have to do to catch up to that point. Presuming that everything until then went right.


I have had a look and can’t tell if I have a duplicate, tried just moving the house and pressing M to remove extra vertices.

Here are my extra images in case they are of use. I fee like I’m probably missing something so simple! I would just move on but I would love to get this boolean modifier working as I want to know how to utilise it in the future.

Yeah, that looks all fine, the Boolean worked (the clapboard above the roof line was cut). Did you read the part I wrote in the paragraph after the “Edit”? That’s how you continue on.

1 Like

Yes that worked great. I just now have the top roof areas with no siding and on one tiny edge too.

Yeah, that happened to me too (not the edge, but I have both missing gables), and I didn’t spend time yet to find out what I did wrong; I was hoping it wasn’t that way for you since I went through it all quick and sloppy. I’ll go back later today and try to figure it out.