Boolean not working right

I’m trying to make a hole in this cube with the boolean modifier although it’s just adding to the cube instead of cutting into it in some areas.

gif of the issue

the file: cave.blend (772.9 KB)

setting the boolean to “exact” (and clearing custom split normals) yields this:

1 Like

How do you get the “Solver” property for your modifier? I don’t see one for mine.

Which Blender version are you using? I think they introduced it with version 2.91

1 Like

Looks like it from experimental build.
I didnt saw this in regular/alpha builds from 2.90 to 2.93LTS. But it still exist in 3.0.0 Alpha.

UPD: I was wrong. Solver Options are appear in 2.93LTS.