Boolean operation gives ... weird... result (or alternative engraving method)

Ok, I have an object (surface converted to mesh) into which I want to engrave a text (text to mesh) using a boolean operation, however the result misses 2/3 of the original object (it just disappeared, see screenshot below). I suppose it has something to do with the way I created the mesh… but no clue as to how I should solve it.

The second screenshot is of the entire object and I want to engrave the text into the heart (might try to 3d print it, so I need to actually engrave it and not only create “the effect of”). So if there’s any better way to do this I am open to suggestsions.

Attachments



Before you boole, make sure objects are clean: [Ctrl] + [N] recalculate normal, [Ctrl] + [A] reset object scale, and in Edit mode [Ctrl] + [V] remove doubles.

Remember you are trying to boole super fine mesh on to coarse mesh. Try reducing mesh count on the text before booleing.

Ok… so I have tried cleaning the objects and reducing the polygon count of both objects to ridiculously low values, which did affect the results, but did not solve it in any way. I also tried only a “L” and only a sphere, in the case of the sphere it worked, with the L I got exactly the same problem, so I suppose it must have to do with how the text is transformed to a mesh, but still no clue how to solve it except if I would write the entire text by hand which isn’t an option, so any suggestions in general or an alternative way of transforming/creating a text mesh? :o

Oh and, Ridix, thanks for attempting to help :cool:

BTW, I added the model to allow anybody to see for himself… or otherwise tell me it’s a problem with my computer.

Attachments

heartpendant_com.blend (329 KB)

I reduced mesh count on the text and the heart object and it booles fine. Idea here is to smooth it with subsurf modifier. But it has too many sharp triangular polygons by the boolied joint, and don’t render well. Some cleanup is needed no matter what you do!

Attachments


Thanks,

Would you know by any chance whether polygons added with subdivision surfaces when they are exported are actually ‘there’ and will be 3d-printed without any problem?

And either way, why isn’t the thing working in the first place with fairly normal objects?