Border Occlude

Do you think the addon would benefit from having shift+ctrl to deselect? I do use occlude in a pie menu is already quick but after testing your addon I think it could be something good to have if it had some deselect option.

There is.

Thanks for your reply. I meant having both functions available. That seems to replace selecting for deselecting?

I’m sorry, I have very bad English. I can not understand what you want
The video shows 3 modes: New select, add selection and reduce selection
You just have to make 3 different hotkeys, like in the video.
That’s all he knows.

No problem I think I deleted some of the keystrokes by mistake so that’s why I was confused too when you showed me that picture.


Yeap, that was it I just created a new keystroke it is now working as it should. Thanks for that picture which made me remember I deleted one of the keystrokes by mistake.

BorderOcclusion for 2.8

Hello everyone!
This addon helps select backface polygons without enabling XRAY or Wireframe mode.
You will spend lesst time clicking for using this operations.
If you worked in modo you probably noticed how cool is that - to select front faces with LMB and backfaces with RMB! That’s why this addon exist.

There are two modes - Rectangle Selection and Lasso. You can switch between them just by clicking on the button in menu

Install -

Download -
Key for hotkey view3d.occlusion_macro


Dont work :confused:


Work with RMB, but dont work with left mouse button.Can You make this work also with LMB?

Most likely you have busy LMB. Have you turned everything off for sure? The script is not tied to the key you choose. Tomorrow after work I will check

1 Like

The addon works with the left mouse button, but you need to make a lot of effort to disable all conflicting functions. I do not recommend using the left mouse button.

I use it with alt+ LMB (with alt+ctrl, alt+shift) tweak

LMB - normal selection
Alt+LMB - Occlude selection

btw. thanks for the script. Very usefull!

I have little problem with icon display:

1 Like

Yes, there is such a problem. I will apply for this bug BF

Perhaps I screwed something up when installing this and trying to get the three new keymaps setup but on the latest 2.80 I get this error as soon as I click on the icon:


Any idea on what I might be doing wrong, or is it because things have changed so much in 2.80? (2.4 KB)

Try this

Sorry for the delay in testing this. The updated file you provided seems to work just fine.

Unfortunately I’m one of those folks that has set up Blender to have a standard Maya control scheme (Alt + LMB/MMB/RMB for rotate, pan, zoom) and it seems like it’d be a huge pain in the butt to find all of the key mappings that conflict with this add-on. But if people are using RMB to select I could see this being really handy (and I’m quite jealous of them for getting to use it!)


I use maya style

Do you use left mouse select? If I set it to right mouse select in the Preferences then I can use the lasso select just fine but using the box select makes it work mostly but the box doesn’t automatically complete when I let go. The box just sticks around, but it doesn’t do that with my normal left-click to drag out a box. I can drag the box out with RMB and then left click to finalize it but that’s pretty awkward.

However if I keep everything the same and switch to using LMB in the three preferences it just doesn’t work at all. Maybe I’ve got something else that it’s conflicting with but I’ll be damned if I know what it would be. :frowning:

Newbie here - sorry for my ignorance.
I’m totally confused as to how to set this up. I followed your instructions, activated the two addons, made three custom shortcuts. I tried to turn off right click everywhere else but I have no idea if that’s what I was supposed to do.

How is this supposed to work when it’s set up correctly? Is there an additional hotkey? I’m lost…

If this is what it takes to make a custom keyboard setup in Blender, I might have to tap out…

1 Like

Guys, I do not know English and can not explain. Can you record a video?

Thanks, the addon is working (i’m using the 0.3 version on gumroad)

i still have 2 issues:

when i press the icon (what is the use of this icon?)

and in edit mode the icon is hidden:


I check error
icon bug here