Border rendering bug?

Before filing a bug report I’m asking here for confirmation (or a solution):
Blender 2.90 (and previous too)
when I set a new Border/Region Render, Cycles renders another portion of the canvas, as if it keeps the previous region. Quitting the render and giving a second hit on F12 solves the momentarily issue.
Does this happen only here? Maybe some addon messes up Blender?

edit: checked, Eevee is not affected

Bumping up…

I am not sure if this is your problem but as nobody else has answered (since July!):

There are two types of render border. The view-port render border and the Camera render border, they are independent.

You can select a border for view-port render in any viewing angle and in render preview mode it will show that portion of the view rendered.

But if you hit F12 the render will be always be from your active camera’s view and will not take that border into account.

To select a border for the camera view you have to select the border in the camera view.
Ie: go to view menu, select cameras-active camera (Numpad 0) and then set your border from that view.

When you hit F12 you render from the camera view and the border that you set in the camera view is the one that renders. Not the border you selected in any other view-port angles.

If you do both (select one border for the camera view and another in any other viewing angle), you have 2 independent borders one for the view-port and another for the camera. To deactivate them you will have to deactivate them separately.

Hope all that makes sense and is useful for you.

If that is not your problem I can not help, border render works as expected for me.

Thanks for the attention. I’m talking about camera border. I noticed this strange behaviour since 2.9 i believe. Though I still have to check if it’s some addon that messes…

Yes, I thought maybe you had a different problem as you say «Quitting the render and giving a second hit on F12 solves the momentarily issue.»

Maybe it does have something to do with addons or preferences, I have not seen any threads related to this behavior and I have tried but cannot reproduce it. I do not know the exact steps you take to get this error.

You could try loading factory presets, this will reset all preferences and disactivate addons that you have installed.

I tried disabling all addons (except Cycles of course) and the bug is still there. Next step is to do a factory settings…

Update: problem solved!
no addons were involved. It looks like my startup file was somehow mangled.
I had to make a factory reset (umpf! all prefs gone!) append all the assets I had in my previous startup file and recreate my beloved layout.