Border select does not work

Hi, newbie here. I’ve tried for hours to get border select to work. When I press “b” nothing happens and pressing the right mouse button will not draw anything let alone a “box.”

I’m in edit mode when I do this. I deselected with “A” so all the vertices are yellow. Pulling hair here. Any ideas?


Well, I tried one more thing and it seems to work. Don’t deselect, select. And press “b” for a length of time ( a circle shows up around the “+” sign cursor ). Don’t use RMB, use LMB. The docs are very misleading.

In Edit Mode: (if your in Object mode you’ll select the whole mesh)

Press “b” once to use the “Box Selection” tool. You should see your cursor change into a dotted cross. Then hold the left mouse button and drag a box around the verts, edges or faces.

Press “b” twice to use the “Circle Section” tool. Your cursor will change into a circle (you can use your middle mouse or num+/num- buttons to change the size). You can now use your left mouse button to drag or selectively click on verts, edges and faces. (doesn’t work in “Object Mode”)

There is also the “Lasso Selection” tool. Hold "ctrl + right mouse button and drag around any verts, edges and faces.

The buttons used also depends on your “View & Controls” settings for your mouse.

I dont know whats your Blender version, but at my Blender (2.42a), the Lasso selection is CTRL + Left Mouse and then Dragging around…

Yellow vertexes are selected ones, you need to press the AKey again to deselect all the vertexes. Also you must have your mouse over the 3D window when you press the BKey for box mode to work.

PS. Use MMB (middle mouse button) in box select mode to deselect.

Oops, didn’t mean to use ctrl + “alt+ rmb in my first post.

Thanks. Appreciate the input. It really helps.