Bouncing lettres


Je suis tombé sur un tuto qui explique comment animer un lettre.
Il utilise deux bones et comme vous pouvez le voire, il déforme la lettre P (en mode pose, et en faisant une rotation au bone supérieur).

J’ai éssayé de séléctionner la lettre puis faire de même avec l’armature (Ctrl + P, puis Automatic Weights).

Le problème c’est que avec Automatic Weights ou bone cela ne suffit pas à créer l’animation (j’ai essayé les autres options. Et ce n’a pas marché)

Pourriez vous examiner le .blend à l’adresse ci-dessus et m’indiquer comment arriver au même résultat,

Merci pour votre aide,


Hi to all,

In fact, I’ve moved a little bit forward,

I still can’t get the same framework as the framework marked GOOD (see image below).


As you can see the bottom of the letter seems to be attached to the ground and there is a slight curvature in the middle of the letter.
Here is my blend (hoping that you’ll make the BAD framework walk away to explain me how do you do).

Thanks to you.

Select your armature, shift select the letter, switch to Weight Paint mode, you’ll see that the weight is not correct, give it a correction with a brush (Blend type > Mix)

in french:

Sélectionne ton armature, shift sélectionne ta lettre, passe en mode Weight Paint, tu verras que le weight n’est pas correct, corrige le avec une brush en mode Blend > Mix


Thanks to you, you found the solution to my problem,
it was necessary to use weight painting.
But I wonder why the GOOD model has 2 Vertex groups.

Your help is welcome.

When you parent With Automatic Weight, it will create as many vertex groups as bones you have, each bone controlling the vertex group that has its name. So in both cases there has been a parenting With Automatic Weight I guess, except in a case it was not correct and you needed to give it some correction, as the top bone was affected to bottom vertices while actually it was not supposed to. Parenting With Automatic Weight often needs corrections, so you can either do it in Weight Paint mode or with the Assign or Remove button under the Vertex Groups list. If you use Weight Paint mode, note that you can paint through with this brush settings:

Is it clear?

edit: As I said you could also have removed the bottom vertices from the group called Bone.001 through the Properties panel: