Bouncy antennae with cloth sim

BrokenCreature.mkv (560.3 KB)
Hi I am trying to get this characters little antennae to bob along while he animates using cloth modifier.
I have added a pinning vertex group to prevent the body from being affected, but it seems to be getting affected anyway.
Any idea what setting to change please?

thanks for looking

The .blend

Took a quick look at the file. You have cloth and soft body physics. The cloth is pinned appropriately, but then it’s running soft body physics on top of that, and the soft body is not pinned (well, there’s no goal group) so the soft body makes everything jiggle.

Generally speaking, if you want physics to be running on only a part of a mesh, make a different, non-rendering mesh to run the physics, and then use a mesh deform modifier to transfer the physics onto your mesh. Just be careful about double dipping on deforms. If you use an armature modifier on the mesh deformer, exclude the mesh deformed vertices from the armature. Or, use a dynamic bind, with the mesh deformer parented to the bone.

Thank you bandages.
Leaving just the cloth modifier in place improves it in that the body is no longer affected, but I don’t seem to be able to tune the effect - it always goes very limp.
In order to test I scrub back to the start of the timeline and hit alt-a – is this the correct workflow?
Sometimes it seems like my tweaks don’t have any effect, should I be resetting something else each time?

Uhh, maybe, lol. In general, it should be. But Blender caches physics, and doesn’t always recognize changes that can invalidate the cache, which can explain what you’re talking about.

When dealing with physics and making changes, it’s usually a good idea to reset the physics cache after every tweak, which you can do by starting and cancelling a translation (grab) on your physics object. (And make sure you don’t have any cache bakes.)

People starting out with physics often make the mistake of focusing on the settings of the physics to the exclusion of the mesh used for the physics. Your settings are only part of the picture.

Think of your softbody mesh as being one of those childhood craft projects where each edge is a straw with a string running through it. Changes to the topology affect the behavior. Changes the vert count affect the behavior.

But you’ll be like, “But I can’t change the mesh, I have it how I want it to render.” So, that’s another reason to create a different mesh for your physics and use a mesh deform to transfer it to your rendering mesh.

1 Like

Another quick thanks here bandages:
Thanks you are a boss! Loads of physics wisdom.

hmm I’m not really getting the right result with this approach.
The desired end result is an exported animated mesh for use in Unity if that makes any difference.
Any other hints? I have added more loops around the base of the antennae, and re generated the physics cache after several rounds of tweaks.
Is this even the right approach?
Should I just rig and hand animate it?
Updated Blend

You could hand animate it, sure.

You could also add more verts to your pinning group, at values somewhere between 0 and 1.

You could also do what I suggested, which is mesh deform from physics instead of doing physics directly, which would let you use sewing lines to pull your antennae in different directions (possibly manually animated).

I’ve been trying that. At the moment the antennae (separate object) detaches and drops like a rock when I go back and scrub the timeline.
With separate object for physics + modifier

You don’t have a pinning group set for your physics object.

You’re also mesh deforming the physics object from the rendering object, instead of vice versa.


Ah that helped. Cheers.

Feels like some progress. I will have another go at it tomorrow.

ver5