Bounding sphere not what it appears... ever

Hiya all,

I’m working with a very basic collision shape: a sphere. I set the radius to about what it should be, and hit the P button and… the sphere is hovering a good .3 blender units above the ground. It “bounces” off of the plane and I see it touch then, but then it just pops right back up higher. Why is it hovering? Why doesn’t the bottom of the sphere just hit the ground?

http://www.free-webspace.biz/pooba/annoyed.JPG

Anger!

-Sam

  • The link to your JPEG is broken (for me at least)
  • Upload a .blend if you can instead please, makes everything much easier.

First of all, drag and drop the link and it works. I think the message “It is not allowed to open files from extern sources” is kinda a given on what to do with that.

This is a basic file. It’s a sphere, made dynamic, and onto a recently added plane. That’s all it is. There’s no fancy things, you can make it in 30 seconds.

Ohh, sorry, I’m used to making all my links work right off the click, so this is a little unfamiliar to me. My mistake.

This is a basic file. It’s a sphere, made dynamic, and onto a recently added plane. That’s all it is. There’s no fancy things, you can make it in 30 seconds.

I already made the working example that you described, and I can’t see anything wrong with it, therefore I assumed that there is an issue in your file specifically.

Sorry that I couldnt be of more help to you.

Social.

did you ctrl + a to apply scale and rotation? try that if not.

just select the object then ctrl + a

Hmm, this is quite strange.

See if you can see anything wrong with this blend file.

Because mine looks like the picture when i do it.

Here:

http://socialstorage.googlepages.com/worksfine.blend

I made a similar scene, and it all works fine for me. I don’t know what exactly you did to **** it up like that in your file, but just do what I did in this example and you should do fine.

For me, all of those objects are floating above the ground slightly.

Yea, that’s an engine thing when your working with specific bound types (like box, cylinder, convex hull etc), it seems to be a collision buffer or something.

Either way, it’s not something you would notice in a 3D view, and a fully textured environment. The separation is so minimal, that it’s only noticable when your looking at it in absolute 2D level ortho.

I think the reason it was so obvious in his setup was because he set his scene on such a very small scale. That in turn made that “buffer space” seem huge, when actually the scene was far too small. Now I know that scale should be a non issue when talking about 3D space, but it seems to play a big part in how the bullet engine handles it.

Keep in mind that the BGE + Bullet engine mix is actually pretty young. I mean this thing was implemented something like 2 or 3 versions ago, it’s a constant work in progress, so expect to find a fair share of bugs.

That said this issue is not really all that critical. There are many other bugs that warrant attention from the devs, such as the scene switch memory leak bug. I hope they get around to fixing that in the upcoming release.

are you sure your radius for the sphere is close or as big as the sphere.

Please read the PhysicsTips before filing bugs:
http://www.continuousphysics.com/mediawiki-1.5.8/index.php?title=Physics_Tips

most common:

  • best to use 1 unit == 1 meter
  • objects needs to be larger then 0.2 units
  • apply scale (CTRL-A)
  • leave the center of the object inside its mesh
    -choose the right bounds type, don’t leave it open
    -for sphere, make sure the ‘radius’ equals its size
    -leave gravity around 10, not much larger

Thanks,
Erwin

Look at these 3 images:

http://img184.imageshack.us/my.php?image=2hikr2.jpg
http://img184.imageshack.us/my.php?image=2lomr6.jpg
http://img267.imageshack.us/my.php?image=g0oduk8.jpg

With bullet physics enabled, you might have to make the sphere a little smaller than your object.

Strangely enough, this is happening to me too :frowning: