Box Select not getting all Vertices

Whenever I use a Box select, I don’t get all vertices. It only selects the ones that are visible in that view. I have racked my brains, but I know it’s something simple I’m missing.

Please help!!

try hiting z first, or anything hidden by a face will not be selected…but i’m not shoure if thats your problem?

youre probably in solid draw mode, switch to wire mode. Or you can change the settings by going into edit mode, there should be a button that has a picture of a cube, when you put youre mouse over it it says “Limit selction to visible”, deselect it.

I think that did it. thanks