Bridge tool is rotating the vertices for some reason??

I was trying to follow along with the coffee cup tutorial on, and things were going well, and then all of a sudden when I went to the specials menu, and then bridge…well, you can see the picture. It rotated everything. Any ideas what I could have done? I never rotated anything before extruding, so I dont understand why it is trying to merge them the way it is now.

I believe I have solved this. I was able to make it work today. Oddly enough, it had to do with the global location. I tried the “other side” of the “coffee cup” (remaining on the x axis) and it worked beautifully. Posting this reply if someone come across something similar.

I didn’t realize the bridge tool was affected by location. Or at least it appeared to be…

I was wrong. Again, I am just posting on this again to help anyone else with a similar issue.
The problem was that I was not rotating the faces toward each other enough. I rotated them on the y axis until they were just about parallel and it worked. I know this because it started to happen again and it was just because I only rotated them just a little.

click the “reverse” checkbox in the operator panel. T to bring up tool bar