Bsurfaces how to use?

Hi
At the request of my students I want to use the Bsurfaces and Bmesh addon in my class but I have not yet looked at them
so I did download the videos and the help but :
I have activated the bsurface in the user preferences and disabled the gpl version as required
But from there nothing seems to be working as shown in the video or the help
If I trace the 3 lines / strokes with the grease pencil I get 3 black lines. that’s all
In the menus on the left I don’t see any menus for bmesh or surfaces…
If I create 3 curves instead of the grease pencil, I get a small menu proposing to select the first point but from there no menus or directions as to how to generate surfaces or else?
What am I missing here?
My release is r53668 Blender version 2.65.6
Thanks for any help
yves

Are you in Edit Mode ?

Bsurfaces is kinda weird in that you have to create at least an object (plane, cube, any mesh will work), then select it and enter edit mode. Once you are in edit mode, you can feel free to erase the plane/cube verts that you used to start from.

After that, you just start gp drawing and making faces like in the tutorials. Hope this helps.

Great! Yes I have tried edit mode and object mode. So as I read there must be an object / mesh to start the process?
As it is explained in the video, they show three lines of vertex or as it is mentioned to use curve. so it would be nice for new users to mention that before a mesh has to exists before starting the process. I have a class of 17 students, university grade that are interested by 3D animation or modeling and simulation in extension of their cursus, but Blender is not an easy subject to sell. I need a lot of persuasion and also learning and researching to keep the lab working. But anyway… Thanks for the help, I think I will make it now based on your inputs
Thanks again
Yves

Ok here is the situation
I have set a series of curves that I transformed in meshes. Qt this point I can see effectively the menu from Bsurfaces with the options of adding surfaces and edit strokes and some other selections to tick. Now I have three curves parallel modified in meshes. I select a first one in edit mode and shift select the two others. I have the Bsurface menu, but if I want to add surface I get a popup menu with load of error messages.
As said in the video, before transforming the curves into meshes, I did set a first point, but I don’t think that the info went through when transforming to mesh, so once I have a mesh I go in edit mode, shift select a second line of vertices and try to add surface but I get a popup showing many errors from the script.
I did try to uncheck the automatic join, the loops on strokes but same results.
Still stuck here…
Something I don’t get here… would it be a version issue ?

Glad you got it working! :slight_smile:

Ya, it is a quirk of how they implemented the addon. Since they based their workflow off of the grease pencil in blender, which can be drawn just about anywhere these days, they needed to limit their tool to only work in the right context; mesh edit mode. I am guessing that they preferred to avoid duplicating all of the work and features of grease pencil. I believe that cgcookie has a great quick introduction to bsurfaces, btw.

As for blender itself, I think this forum is a great example of what can be done with a little bit of elbow grease (<— not a grease pencil pun!) :wink:

Anyways, glad I could be of help, and good luck to you and your students! o/

thanks
. yes I follow the forum as a silent spectator reader trying to get as much info as possible. Students are not patient and if something does not work immediately as they expect, they disconnect.
We have some projects of animation and I intent to drive through
coming back to the issue I will try again with the grease pencil, maybe I did something wroing somewhere…
I’ll let you know.;

I just created 3 lines of strokes in gp but they stay black lines, I tried to convert in path and in curve but nothing happened!

I just created 3 lines of strokes in gp but they stay black lines, I tried to convert in path and in curve but nothing happened!
I get an error message if I try to convert them in path or curve, saying “current grease pencil strokes have no valid timing data”??
First time I get that type of error…
In fact we had tried to use the gp last year but no success…

Make some 3 different size Bezier circles spread on z axis. select them and Ctrl-J join.
Add plane.
Select joined bezier AND plane. Hit Tab to edit mode.
Click Add Surface.

Did it?

@eppo
Hi eppo. We have been trying to get grease pencil and Bsurfaces working without success. I believe it must be a matter of release but we could not explore all the releases going back in time. At the present we are using releases from Graphicall version:
r53555 r53584, r53556, r56242, r53668 on three machines all running windows 7 with i3 cpu dual core, 4 gb ram and nvidia cards
On all machines we got the errors messages you can see on the photos
We did follow your suggestion to create first the 3 circles bezier, the the plane, then joining the circles and the plane. Then tab edit
In some cases the bsurface was not showing up, in other cases when it was present, it did generate the error message you can see on the pic. I will download the blender official release to test if we get similar problem.

Attachments




Try an official blender release not some experimental version from graphicall.org. Just tried with the official 2.65a and no error messages. Assuming this is for some teaching would it not be sensible to use a proper reference version, the official versions are always readily available

i just tried the official release 265 and we got the same situation where adding surface generates an error msg with many lines of error. The popup does not stay if I want to make a screen grab so I will do a pic from my camera.

Attachments


We are discussing about the possibility that having many releases on the same machine/folders could be an issue?
When I look at what people do with the grease pencil and bsurfaces I wonder what differences can be critical like os or cpu or else??
Among the students we have tested 5 machines now in different os win 7 and xp and we got diverse errors messages or no results.
My machine is in English setup but the others are in french so language may not be the issue…
No I believe that we are not doing things in the proper way or order or there is a version issue between the blender version and the scripts…

One thing, is it ‘normal’ that after we selected the three rings then the plane, then did tab edit, then add surface, the plane got deselected? As you can see on the pic, tabbing edit deselect the plane?

Here is the latest error msg we got with the official release. Now we are looking over 2 machines if they are doing the same results with the same os and version.

Attachments


I have activated the bsurface in the user preferences and disabled the gpl version as required

If i recall right there were 2 versions of Bsurfaces for some time GPL and paid one. Now there is only GPL version 1.5 left.
Not sure, maybe release you use comes without Bsurfaces and you download it additionally? Again, nothing to disable.

I use what comes with different builds from builder.blender.org with no errors when i follow what i described.
While builds on builder are not “official” - might contain bugs, my experience with it shows opposite most of the times.

To use Grease Pencil is mostly the same like curves. I set 2 different views, add plane and switch edit mode. Delete all vertices of plane and add some Grease pencil strokes. To part them in space position 3d cursor in other view and draw some in the first. The rest is just a matter of Add Surface and further build upon it using ordinary blender tools mixed with Grease pencil and Bsurfaces.

May i suggest using screenshot tool, like Alt-PrtScr button and MSPaint? Photos are less clear and do not show all screen area; your Outliner contents could be of use e.g. too.

Edit: OS for the most blender works i use is Linux Mint 64 bit, blender r53716. Just checked r53669 on Windows XP 32 bit - Bsurfaces is functional, no errors. Both builds are from builder.blender.org.

Ok thanks we will do that.

we have tried the latest 2.65a and similar issues. error msg or no action.

Ok here’s an example step by step as i don’t know where you’re making a mistake

  • Using the official stable 2.65a release (avoid graphicall builds for educational processes, as Richard Marklew said, they’re experimental, most do not use the same compilations flag as the official release and some have experimental features).

  • In Object Mode, i add a Mesh -> Plane
    http://i.imgur.com/ujiF4.jpg

  • In Object Mode i add a Mesh -> Circle
    http://i.imgur.com/61VlN.jpg

  • I switch to Edit Mode (the circle must be the only object selected, not the plane)
    http://i.imgur.com/iM25Y.jpg

  • with the whole circle selected i press G (to move) then Z (to constraint on Z axis) and move the circle up
    http://i.imgur.com/n0Tzp.jpg

  • I press SHIFT+D to duplicate the selected circle, then i press G then Z to move this new circle up
    http://i.imgur.com/9sJxg.jpg

  • I press S to scale that selected circle
    http://i.imgur.com/oI3Ra.jpg

  • I do again SHIFT+D to duplicate the circle , then G + Z to move that 3rd circle up, rescale it so in the end i obtain something like this
    http://i.imgur.com/A0XHs.jpg

  • I switch back to Object Mode, i have then 2 separate objects : 1 is the plane and 1 is the 3 circles .

  • I select the “3 circles” object and press ALT+C (or click in the bottom menu on Object -> Convert To) then select “Curve from Mesh/text”
    This is converting those circles into curves object

  • I switch to Edit Mode and select all if it’s not already done
    http://i.imgur.com/g3qqw.jpg

  • In the Toolshelf (panel to the left of the 3D View) i click on “Set Spline Type”
    http://i.imgur.com/fsFmO.jpg

  • In the popup, select “Bezier”

  • Go to Object Mode

  • Select the object made of the 3 bezier circles, hold SHIFT and select the Plane object
    http://i.imgur.com/7zFwZ.jpg

  • Go to Edit Mode and make sure the plane is selected
    http://i.imgur.com/e4dXX.jpg

-In the bottom of the Toolshelf , in the Bsurface tab press the “Add surface” button
http://i.imgur.com/Cy5Ql.jpg

Result :
http://i.imgur.com/jfixd.jpg

Press F6 (or look into the operator panel, under the toolshelf) to tweak the settings