Buffer shadows won't work

Hi,

I have some problems with shadows.
Everything is ok with raytraced shadows but the rendering time is too long.
So I would like to use shadows buffer. I know there is a lot of docs and threads about it but I still can’t see the solution.

What I do is :

  • use a spotlight
  • use shadow buffer
  • test several settings with samples, bias, …
  • use right values for shadow clip start-end
  • in material buttons, select Shadbuf and Shadow for each object
  • in render buttons, select Shadow.

And still no shadows in rendered image … I don’t see where I have made a mistake but there must be at least one :smiley:

Any hint would be appreciated !

Chhhub

Is it possible to look in a sample file, because your settings should be O.K. so far ?

I can’t send you my .blend file because it is too big !
I just tested with a very similar but simple example and i get buffered shadows …
I really don’t know what is wrong.

I’m representing the solar system with realistic values. That means that planets are really small and the spot (in fact the Sun) is far away from planets and satellites.
Can it be the starting point of my problems ?

Probably. You’ll need to focus those shadows very tightly (low angle) in order to see the objects if you’re really using a realistic scale.

That did the trick ! Thanks. Lowering the angle was enough.