Bug between ray tracing and new hair?

I’ve been getting this weird problem with ray tracing and the new static hair off and on with the new releases.


The weird thing is, it will sometimes be in one eye, sometimes the other, and sometimes not there at all, and there doesn’t seem to be a rhyme or reason to why it changes, other than I’ve noticed it often switches when I move an object in the scene, even just a tiny bit, the next time will often be different. The eye is set up with a raytraced outer layer, a sphere with a UV eye texture, then a hole in the middle, and a black, non light reflecting circle behind the hole. As you can see, this is where the problem seems to be, but the material settings seem to be completely normal, and I’ve checked over and over. This happens on two different computers too, so I know it’s not just this machine. And the fact that it randomly will switch, says to me it’s some kind of rendering bug. Any thoughts, tips, suggestions?


Here is an example of why it’s weird. All I did was add this cube. That’s it, period, no other settings changed. Just went add, mesh, cube, and rendered, and wha-la, no weird eye thing.


I first thought that your hair is also inside the head and can bee seen through the eye. The cube thing is puzzling me though.

Can you send/post a blend? I am interested in the solution.

Here is the blend (no textures). If you render right off the bat, you should see the render error in one of the eyes.

http://blender.isoserv.com/uploads/Yoda Error.blend

(You’ll have to copy and paste, I forgot to take out the space.)

I just rendered it and I don’t see any hair in his eyes as your picture shows.

What version are you using? And both eyes should have distinct black pupils. In my render, his right eye is all white from the hair in the background.

I simply redownloaded the file, opened it and hit render and this is what I get on Blender official release 2.40. Notice his right eye, (left as your looking at it.)


Ok, yeah I was only looking at his left eye. His right eye does still have hair in it. This is strange though, as I turned down the particles emitted to 1 and it still had the error. I added the cube as you did and it was fixed. I can’t help you on this one, but at least you know its not your computer (I used 2.40a release).

Ok, I fixed it, just duplicate your eyes (both eyes) and then delete your current eyes.


Fixed .blend:
(Tell me when/if you want me to take it off my webspace)
Edit:Link Taken Down 12/29/05

I think I spent an hour with your blend file and all I can give you is this close-up of the eye:


When you use Z-Transparency, the eyes are OK, but I can’t explain what’s really happening.

I have no clue how your eye mesh shall work, why shadows are disabled etc, so in the end I gave up. Hope my render will help you.

Area lights need to be bigger to look good, I also think you should use buffer spotlights, they render a lot faster

Hey, thanks for taking the time to look at it. I dissabled shadows just to increase render speed, as it doesn’t seem to effect the problem, and the lighting setup was again quick and simple to keep render times fast.

And thank you Forte. I’ve tried this before, making copies and deleteing the old ones, and the problem seems to come back, but it’s fixed for now, and hopefully it was just a bug in the prereleases that was causing it. Thanks again for your help.