Bug found when exporting obj, and importing obj

I don’t know if it happens on teh export or import, but it seems like every vertice gets a double. The model looks fine in the view. When trying to apply smooth shading, the faces will not smooth. Remove doubles fixes the problem with smooth shading. According to the count of vertices, the entire model had a double. Version 2.8 blender.

See different import/export options in the panel. Your model might have been split into individual faces during process, this happens for instance with .dxf

1 Like

I will look at this next time I use export obj.

Probably EdgeSplit modifier was added before exporting. Then depending on the settings while exporting modifier is applied and hence double vertices are created. If removing doubles vertices get merged and smooth shading will smooth normals as usual while you lose normals’ setup which was created.

This is normally due to “split normals”. With an object selected, check the gemoetry tab under “gemoetry data” and see if it says “Clear split normals”.