Bug in hair particles?

Not sure if this is the place to post this, but there is something weird with the hair particles. This is in 2.58, and I have tried it on both the Linux ad Windows versions.

I added a mesh plane and then put a particle system on it and set the emitter type to hair. My idea was to animate the particle system.

First I tried to set a keyframe on the number of particles, which apparently isn’t allowed (and perhaps this kinda makes sense that it isn’t)

However… next I tried to keyframe the length of the hair. It lets you set a keyframe (say on frame one), but when you go to a different frame (like frame 30) and try to set a second keyframe on the hair length, you cannot change the value. Dragging doesn’t work, the value changed, but the minute you let go, the value goes right back to what ever it was for the first keyframe you set. The color of the input box changes, just like it does for other such keyframes, but it just doesn’t work. I have tried typing in a value, and it does just the same thing.

So is this something that isn’t supposed to be keyframable? In which case why does it let you set the first keyframe?

Select the Regrow tickbox