Bug in the Draw Extra>>Wire Mode?

When i try to preview my mesh in the Draw Extra Wire Mode some lines are not displayed at all, at first glance i thought it was just the lines that where made through LoopCut, but now i see that another lines aren´t displayed neither.

Edit Mode:

Draw Extra in other Modes:

Is it a bug, or is it the way it might be? some way to fix it?

I think this is very important for when i m creating an armature those lines would let me know where the joints of the bones might be in relation with the mesh cuts for deformation.
thank you

is the one edge on the bottom of the mesh? If so then just do draw type wire not draw extra wire and draw type solid/shaded.

By default the DrawExtraWire Mode displays only edges with faces angled not 0.
If two faces are sharing the same orientation of normals, none edges are drawn.

However you can force to show all edges by selecting the “All Edges” option in the EditButtons MorePanel in EditMode


Hey Pat, great! Sometimes i wish Blender shows related tasks in the same panel, sometimes you hafta be going from one tab to another till you get annoyed.
thank you very much