bug? "keying set failed to insert any keyframes" error

I used autokey, then tried to manually keyframe the loc of my camera (which happens to be using a track to constraint - tried deleting it too), and I get this error.

Alpha1 and SVN versions, win64.

I understand it’s aligorith’s commit, so he can probably help me the best.

I tried closing Blender and re-opening it.
I can’t replicate it in a new file with a basic cube or camera anim.
adding an object or trying to key an existing object without keys also gives no error.

ideas?

nevermind… I think I figured it out.

The Location channels for my camera were locked. Don’t know how that happened.
Warning popup should indicate this more clearly maybe?

Wait! I have just run into this issue too… however, I’m not finding any locked location channels. Can you tell me where to look? (in Alpha2)

in the curve editor

i just ran into this same problem and i’m not finding anything in the curve editor…

im trying it with armatures though so i dont know if that changes anything.

Don’t know if you found it yet, but in the timeline there’s a dropdown for ‘Active Keying Set.’
Mine somehow got set to ButtonKeyingSet, which is either undefined or useless for what I was doing.
Switched it to LocRot and now I don’t need to start over (except the $%#$%@ feet but that’s another story!)

I guess I hit a mystery hotkey.

Dave Heinemann, 5th-year noob

3 Likes

Thanks for this, I was getting rather frustrated.
Did any of you find out if this was because of some obscure hotkey? Because I can’t for the life of me remember having locked off the channels in either the dopesheet or my curveeditor.

Fritzmer: TAB is hotkey for locking channels…

i had this problem to with one bone half way through animating, the way to i fixed it is on the far left of the action editor by the names of the bones there is a padlock symbol, if its locked the thats your problem :RocknRoll:

No need to resurrect a 2-year-old thread that’s been resolved.